JUMP TO SOLUTION Solved

Original topic:

Everything works/syncs except Samsung Health

(Topic created: 02-23-2024 06:13 AM)
438 Views
Yosowasabi
Asteroid
Options
Galaxy Watch

My phone and watch communicate perfectly. Everything functions as it should be.

EXCEPT Samsung Health SLEEP DATA. All other SHealth data syncs properly. I can see my current heart rate change/update within the phone app, along with my watch. Everything else stays synced. I have restarted both deceives multiple times. Toggled on/off multiple times Bluetooth, WiFi, airplane, power save mode. Made sure all apps are updated on both devices. It still refuses to sync the sleep data. I cant think of what else to try except to make a forum post.

The other thing with SHealth on the watch is that it wont open on the phone. When I click on any of the areas it says "Show on phone" the watch flashes the screen telling me to connect to phone with bluetooth and try again. It does this even tho most the data syncs (everything but sleep)

Absolutely mind-blowing when things like this happen all of a sudden. And specifically when it only affects a tiny super specific part of the system.

1 Solution


Accepted Solutions
Solution
Yosowasabi
Asteroid
Options
Galaxy Watch

For some reason the bluetooth settings have to be selected to allow calls on the watch. I never changed that setting or if turned it off, i did months ago so it doesnt make sense either way that the issue I encountered all of a sudden happens. 

I turned off calls to bluetooth BUT THE WATCH IS STILL CONNECTED ACCORDING TO THE WATCH and everything works/syncs **Except the original issue**

My original post issue is solved be ensuring the phone has "used for calls" turned on in bluetooth settings for the watch.

...Its not really a solution due to now Ill be receiving calls on my watch and have to switch to my phone. Why ant these giant corporations make software that works properly?? Absolutely amazing how flawed most big software is these days. 

View solution in context

3 Replies
chrisgconey
Astronaut
Options
Galaxy Watch
I would say to check your permissions... everything else is working smooth so make sure those permissions are allowed ... make sure you keep your bluetooth on and stay connected on galaxy wearable... lastly if the issue still persists, delete the app and re-download it... sometimes you just get a bad download file... if you have an older model watch, then they are not capable of sleep tracking
0 Likes
Yosowasabi
Asteroid
Options
Galaxy Watch

Thanks for taking the time to respond. But what you said makes no sense for this situation and doesn't even attempt to correct the issue. 

0 Likes
Solution
Yosowasabi
Asteroid
Options
Galaxy Watch

For some reason the bluetooth settings have to be selected to allow calls on the watch. I never changed that setting or if turned it off, i did months ago so it doesnt make sense either way that the issue I encountered all of a sudden happens. 

I turned off calls to bluetooth BUT THE WATCH IS STILL CONNECTED ACCORDING TO THE WATCH and everything works/syncs **Except the original issue**

My original post issue is solved be ensuring the phone has "used for calls" turned on in bluetooth settings for the watch.

...Its not really a solution due to now Ill be receiving calls on my watch and have to switch to my phone. Why ant these giant corporations make software that works properly?? Absolutely amazing how flawed most big software is these days.