JUMP TO SOLUTION Solved

Original topic:

Samsung TV (QN90A) + Soundbar (HW B650 3.1) dolby atmos delay on PC

(Topic created: 06-24-2023 07:02 AM)
DiabloSoul
Asteroid
Options
Home Theater

Hello.

I am currently having 2 problems with my soundbar.
First problem is Dolby Atmos sound format has delay of 100- 200 ms all of the time, and without using "dolby atmos" format, i am bound to PCM 2Channel audio format ( displayed on my soundbar when i press "i" button).
Second problem is, even though I have active licence for DTS: X. I cannot enable it anywhere.

My specs are:
QE50QN90A Samsung NeoQled TV.
Samsung HW B650 EN soundbar
Windows 11 PC with AMD GPU.


My connection is set up like this:
PC ( AMD gpu) linked with HDMI 2.1 cable -> TV
TV linked with HDMI 2.0 ARC cable -> Soundbar.

First problem;

I have just recently found out  that I can use "dolby atmos" on my Soundbar since i got active licence, after trying out for a bit i quickly found out that i have about 100-200MS sound delay on all content.

What I have tried:
- Checked Audiosync option and in Tv option for audio delay, both are on 0. I have also tried setting both to max but problem wasn't fixed by it.
- Tried 2 different high speed HDMI cables ( TV - Soundbar), on both instances there is same amount of

449930c2-5727-4f73-b2b4-0eda1aaaa18f.png

 delay in audio.
-Tried swapping out cables, I instead used connectivity like : PC (/w 2.1 HDMI-> Soundbar ( / w 2.0 HDMI ) -> TV. This way I have lost option to use 4k and also don't have any format option as seen in "pic.1"
- Checked driver updates, TV firmware update and Soundbar firmware update - all of them are up to date.

- Tried messing around with local audio drivers and with TV & soundbar settings.

There are many topics regarding this but there isn't definite answer / fix. I am wondering is there anyway to troubleshoot this?

 Second problem;

After installing DTS Sound unbound app, I quickly realized I cannot turn on DTS: X ON.
I have checked surround options, saptial sound options but there isn't any option to turn it on. 

On my headphones, I could enable it easily just by going into control panel > sound > and then set saptial sound to DTS: X but here I don't have any option regarding this matter.

Screenshot 2023-06-24 155754.png

Since I am newbie when it comes to audio and stuff like this I am asking for any help what so ever  🙂
If there is any info you need, please feel free to comment and I will answer as soon as possible.

 

PS: I couldn't set images to fit the page correctly, sorry about that in advance

 

1 Solution


Accepted Solutions
Solution
Samsung_Moderator
Community Manager
Community Manager
Options
Home Theater

Thank you so much for reaching out! This forum is for the support of US products and customers. We do not have the ability to support models outside of the US. There are differences between the US and International firmware, which we do not have access to. Since your product was purchased outside of the US, please visit the link below for support in your area. https://www.samsung.com/us/common/visitlocationsite.html

View solution in context

0 Likes
Reply
1 Reply
Solution
Samsung_Moderator
Community Manager
Community Manager
Options
Home Theater

Thank you so much for reaching out! This forum is for the support of US products and customers. We do not have the ability to support models outside of the US. There are differences between the US and International firmware, which we do not have access to. Since your product was purchased outside of the US, please visit the link below for support in your area. https://www.samsung.com/us/common/visitlocationsite.html

0 Likes
Reply