JUMP TO SOLUTION Solved

Original topic:

Samsung Odyssey Neo G9 G-sync Blanking Issues at 240hz

(Topic created: 04-12-2022 06:34 PM)
user7yvFLAgbDZ
Asteroid
Options
Monitors and Memory

Before I get into my issues, I'd like to point out my inference, which states that my problems with this monitor are (hopefully) firmware/software related. I hope this feedback will be used to make the following updates for this monitor fix more problems.

So,

My monitor has some problems which all stand out on their own. If I were to choose the most significant issue of this product, then that would be blanking -- and the fact that it has G-sync-Compatible certification on its' chassis... I did begin to find this monitor behavior more frustrating when the same blanking occurred on my replacement unit (which had the same problems, minus the dead pixels).

As for installing the first new driver in several months for this monitor (1011.0), I can confidently admit that the blanking issues have slightly changed in behavior (perhaps positively) -- with the added bonus of a slightly better HDR viewing experience. However, the blanking still occurs -- one of the many reasons I think NVIDIA won't add this Neo G9 to their G-sync compatibility list (but that list isn't Samsung's job). The vertical corruption artifacts a little to the left of the display's center also seemed to have changed for the better (less common after the firmware update).

Moving on to the VRR-control function. I can understand that flickering is solved with this mode, but scanlines still occur due to a certain mix of dark and blue colors on the display. Micro-stuttering of v-sync magnitude still overshadows the G-sync smoothness when VRR-control is active... And it only partially alleviates blanking during gaming.

Now only my words and claims can make this feedback more convincing of the fact that this monitor needs better firmware. These were the conditions of the setup as I spent troubleshooting:

  • I have ensured proper cable connections (nothing was loose)
    • I have also tried different cables, different ports
  • Done resets
  • Unplugged and replugged the monitor and PC
    • Waiting minutes before replugging the monitor power cable to the outlet
  • Stable power from the wall and PC...
  • No excess amount of electronics near the monitor
  • Hardware/firmware/software updates OR Full resets (clean Windows 11 reinstalls)
  • Default system/hardware settings 

I want to state the somewhat guaranteed workarounds that almost fully avoid blanking:

  • Running games in borderless instead of fullscreen (strangely, no massive difference in perceived stutter/fps/input lag)
  • Disabling HDR -- one of the main reasons I purchased this monitor (which thankfully had its' HDR performance fixed).
  • VRR control (as I mentioned)

I'd also like to make my position clear:
Nobody deserves to rely on the uncertain future of expensive products' live-service-like updates. Granted, we also don't deserve to know about how Samsung monitors get their new updates developed (unless Samsung decides otherwise). It would make me, and perhaps many possibly angry customers, happier if Samsung at least acknowledges these issues of their flagship gaming monitor: Flickering, scanlines, VRR control stuttering, and especially blanking.

 

The main parts of my PC, if such specs would be needed for additional description:

  • I9 10940x
  • 128GB RAM
  • RTX 3080ti

 

Anyone with this monitor and the same issues, please leave a message here.

That is all for now.

 

Thanks! 🙂

1 Solution


Accepted Solutions
Solution
user7yvFLAgbDZ
Asteroid
Options
Monitors and Memory

I have found a fix for blanking/black flickering issues at 240hz HDR -- it even significantly reduced vertical line flickering on the desktop/certain contents/games!!!

 

The cause of blanking/black flickering was GPU downclocking -- as per NVIDIA's default "normal" power mode.

^^This is why DirectX 9 games were the most affected because the "normal" GPU power mode made the GPU downclock since these games are non-demanding.

VRR-control OFF without GPU downclocking minimized black flickering even more (it can still happen, albeit the least amount of times...above zero).

SO:

  • Use "Prefer maximum performance" for games (or globally) from the NVIDIA Control Panel.

  • Use VRR-control.

 

I wonder if this is a monitor firmware issue or an NVIDIA issue (or both?)...

View solution in context

0 Likes
Reply
2 Replies
user7yvFLAgbDZ
Asteroid
Options
Monitors and Memory

A quick update on my issues (and a newer issue):

I have discovered that setting G-sync in my NVIDIA control panel to only work on fullscreen applications now also works for DirectX 12 and Unity engine games. These games almost always run in 'fake' fullscreen (borderless window). What matters is that after a while of playing with this kind of G-sync mode setup, I have discovered another behavior. The frame times/FPS in my games run more consistently. Despite the reduced stuttering, the non-smooth behavior of VRR control still persists across the board ('jittering').

...You could say there could have been background apps/programs that, while not actively using g-sync, still had some impact on G-sync on games I was actually playing...

One other issue I forgot to mention came into existence after updating the Neo G9's firmware from 1008.0 to 1011.0. After the update, many games running on the Source 1 game engine do NOT use G-sync when launching in fullscreen mode (CS:GO, CS:S, TF2, GMOD...). They either need to be launched in windowed mode (including borderless). Switching to another display mode and back to fullscreen in-game engages G-sync (but it's just a workaround to the issue).

0 Likes
Reply
Solution
user7yvFLAgbDZ
Asteroid
Options
Monitors and Memory

I have found a fix for blanking/black flickering issues at 240hz HDR -- it even significantly reduced vertical line flickering on the desktop/certain contents/games!!!

 

The cause of blanking/black flickering was GPU downclocking -- as per NVIDIA's default "normal" power mode.

^^This is why DirectX 9 games were the most affected because the "normal" GPU power mode made the GPU downclock since these games are non-demanding.

VRR-control OFF without GPU downclocking minimized black flickering even more (it can still happen, albeit the least amount of times...above zero).

SO:

  • Use "Prefer maximum performance" for games (or globally) from the NVIDIA Control Panel.

  • Use VRR-control.

 

I wonder if this is a monitor firmware issue or an NVIDIA issue (or both?)...

0 Likes
Reply