Original topic:

Galaxy Book S (ARM) Cannot Update to Windows 10 2004 20H2 Bluescreen Stop Code Paneldriver.sys

(Topic created on: 12/23/20 3:51 PM)

I have a brand new Galaxy Book S (ARM/Verizon) which, out of the box, cannot update beyond Windows 10 release 1909.


Following a factory reset, the device is at Windows 10 version 1903.  The first run of Windows Update takes the unit (smoothly) to 1909.  Then, on a subsequent check for updates, I'm offered 20H2.  The initial stages complete correctly, all of the "Getting Things Ready" and (online) "Installing" sections run, and then the computer asks to be restarted.   The unit restarts, and I get the blue fullscreen "Working on Updates / Don't turn off your PC, This will take a while / Your PC will restart several times." screen.


The screen proceeds to about 24%, and then does a reboot.  The screen re-appears after that first reboot at about 30%, and, within just a minute, gives me the blue sadface "Your device ran into a problem and needs to restart" screen.   It says:



What failed: PanelDriver.sys


After that, I am rolled back to Windows 1909.


This is fully reproducible on this unit.  Any attempt to move to 20H2 fails with the above code.






Looking around the internet, here are the things I've tried:


1. Factory reset, and repeat, this happens every time.

2. Ensured all devices (USB mouse) are unplugged during the upgrade, didn't help.

3. Tried DISM /Online /Cleanup-Image /ScanHealth, it reports no issues.

4. Tried SFC /scannow, it reports no issues.

5. I've tried ensuring that drivers are updated; however, there is no "Samsung Update" for Windows on ARM - the version in the Microsoft Store only runs on x86 platforms, it will not install on ARM.

6. I've tried using the Windows 10 Upgrade Assistant; however, it refuses to run on ARM, with a message that it is only supported on Intel.

7. I've tried the Media Creation tool, but it also will not run on ARM.

8. I've looked for bootable ARM Windows 10 20H2 ISO images, but they do not exist (except, apparently, for Raspberry Pi, which seems off point for this.  Microsoft offers recovery images for the ARM-based Surface Pro X, but I cannot locate any recovery images or other options for the Galaxy Book S).


Online, I've observed that other people have reported this problem, but I can't view the threads, they just show up in the Google cache in partial form, without a solution.


I tried to locate this "PanelDriver.sys" driver file in the Device manager. It shows up under "System Devices" as "Samsung PanelDriver Device". It says Driver Date: 8/7/2019, Driver Version, and the C:\Windows\System32\Drivers\PanelDriver.sys file shows a version of Alongside the first update to 1909, there is a "Samsung System Hardware Update - 2/13/2020", and after that update, the Driver Date is listed as 1/2/2020, Driver Version, but the PanelDriver.sys file is still listed as version


So, rather than trying a rollback (which would have left me with the same PanelDriver.sys version) or an uninstall (which would have reinstalled the driver on the next boot), I moved the PanelDriver.sys file from the drivers folder to my Desktop, and rebooted. I then confirmed in Device Manager that the driver did not load and was missing. Without that driver all the hardware still seems to work fine, nothing was missing.


However, after moving the driver away, Windows offered me the 2020-12 Cumulative Update for Windows 10 Version 1909... and while that installed successfully, Windows Update is no longer offering me 2004 or 20H2.


So it seems no matter what I try I cannot get onto the latest version of Windows, and although 1909 is still current until May 2021, it seems to me like this driver is somehow problematic and preventing updates beyond that point.


I would appreciate any guidance and/or information on how to solve this problem, and/or how to get my Galaxy Book S up to the latest version of Windows please!


4 Replies

This seems to be an issue with Samsung laptops running Windows.  My Book S is stuck on 1909 as well.  We can only hope Samsung gets it together and supports ARM.


I'm not sure it's fair to generalize and imply that Samsung somehow "doesn't have it together," nor would I say that about Microsoft either.   I think Samsung does a very good job generally; these forums tend to attract people who have had problems and/or might have more negative attitudes due to challenges they've faced, and that's true for any brand.  The reason a computer might be stuck on 1909 is generally not necessarily the fault of the device manufacturer, but is primarily due Microsoft detecting an issue... somewhere... and putting a stop on that device model specifically.  I suspect that is what has happened here.


In terms of that Flex owner in the other thread, the original post didn't say anything helpful, so there is very little to go on.  But rather than just bashing Samsung, if I were in that person's situation, I might do things like review the Windows 2004 stop list https://docs.microsoft.com/en-us/windows/release-information/status-windows-10-2004 and make sure I had all the driver updates and so forth - basic steps that the reporting person didn't even mention taking.   And of course, since the Flex is on Intel, that individual could choose to install and run Samsung Update, and could choose to do a manual download and install of 20H2 from https://www.microsoft.com/en-us/software-download/windows10 if they wanted to.


No, the challenges with the Galaxy Book S, I think, are due primarily to the fact that the device is an ARM device, and support from both Samsung *and* Microsoft is sadly lacking in that area, still.  On the Microsoft side, for example, there is no way to (legitimately) download a clean Windows 10 ARM installation device or image, from anywhere  on Microsoft.  There is no "Upgrade Assistant" on Microsoft.  Indeed, there is no way to recover the device *if* the hard drive fails at all.  Microsoft has made the choice to only permit OEMs to deploy Windows 10 on ARM images, consumers and end users have been - thus far - deliberately denied that option by Microsoft (cf. https://answers.microsoft.com/en-us/windows/forum/all/microsoft-windows-10-arm-licensing-to-end-user... et al).   On the Samsung side, there is no Samsung Update for ARM (the MS Store version literally only runs on Intel, and the MS Store version is the only usable version there is anymore.), there is no recovery ISO or driver download area or anything on the Samsung website, and there is almost no technical data at all.  Indeed it seems to me that the Galaxy Book S - being an ARM device - is being treated both by Microsoft *and* Samsung as, essentially, a "throwaway" consumer device.   That's a key difference between Intel and ARM that I think needs to be made more public.  Had this happened on my Flex, I could just download a 20H2 installer and go for it.  On ARM - neither Microsoft nor Samsung have made that option available at all.


I hope that, at some point, both companies bring the same level of support to Windows-10-on-ARM as they offer for Windows-10-on-Intel; I suspect that it's taking them a long time to ramp that up, and that isn't very surprising given the scope of the task. 


In the meantime, what we have here is a driver (paneldriver.sys), which works just fine for the release of Windows (1xxx) that it was written for... and we have a series of new releases of Windows on ARM (2xxx) that cause that particular driver to fail.  It *may* be Samsung's to fix, but the fact that it is breaking on the 20H2 update really doesn't mean that either company doesn't "have it together" or doesn't "support ARM'".  It's just (more or less) bleeding edge technology, and some kinks like this are to be expected.


It is my hope that my original post above will get the attention of someone who can actually do something about it, and get that driver (or Windows) updated so that they continue to work together.



Hello, I too suffered from not being able to update blue screen constantly. It actually took me months to finally get the galaxy book s up to where it would update on a regular schedule itself got it up to the current version of Windows. Believe it or not the raspberry pi method actually works it is the way that I was able to to get everything up to date and to wear it would do things automatically.

     However, after it was running relatively smoothly well outside of overheating and now it won't even power on blue light just blinks at me. It taunts me in fact I've tried all different button combinations and I can't get it to come on. Actually once I did get it to come on but I forgot what buttons I pushed to do it. So it is possible to get up to the current version of Windows and for it to go on and update regularly by itself but that's where I have a another gremlin that I'm trying to hunt down. Good luck.


***** SOLVED *****


Okay, I read the other replies, and I appreciate them.  I'm not comfortable with going the RPi route, since it's really *really* unsupported and you don't know what you're getting in that image.


But I did reach a solution for this.   After getting the 202101 Cumulative Update for 1909, and rebooting, I was once again offered the 20H2 update.   PanelDriver.sys had not been changed or modified, so I had no reason to expect this was fixed.   So I took the following steps:


1. Rightclick Start->Device Manager->System Devices->Samsung PanelDriver Device.

2. Go to the second tab  ("Driver"), hit the last button ("Uninstall Device"), choose the checkbox to uninstall the driver files as well.  Hit OK.

3. DO NOT RESCAN FOR CHANGES - Just quit the Device Manager

4. Open File Explorer->Local Disk C:->Windows->System32->Drivers

5. Find PanelDriver.sys, drag it to the trash can.

6. DO NOT REBOOT YOUR COMPUTER - Just close the FileManager.

7. From Settings->Update, start the 20H2 update.


I watched the whole thing roll - by the time of the first reboot the system had not reinstalled PanelDriver.sys - and the entire upgrade proceeded correctly - with several reboots in between.


At the end, I had 20H2, and PanelDriver.sys (the same, old version) had been reinstalled, and everything now works perfectly.


Something in that driver is conflicting with something in the 20H2 upgrade process... but it seems to me that it works fine otherwise.  Perhaps this procedure will be needed again for future feature updates, but it got me from 1909 to 20H2, so I am content.


View solution in context