Original topic:

How can I transfer SD Card Files to my PC?

(Topic created: 11-10-2019 05:31 PM)
2347 Views
userTQT3zGTEEL
Asteroid
Options
Galaxy S Phones

Hi

 

Can somebody please assist? I have a Galaxy S8+ and have added a 32GB SD card which any photos and videos are since stored on. The problem is, that I need to transfer them to my PC but cannot find a way to do that!

 

The files total 6GB and can be viewed via the Samsung MyFiles app, but I cannot see any way to save or transfer them to another device.

 

(Although it does have the option to select any/all files and delete them.)

 

When I connect to my Win 10 PC file manager to inspect the SD contents, it shows all the expected directories, but no contents in the Pictures and Videos folders.

 

Unfortunately, my new PC does not have a card reader built in.

 

I've spent hours trying to work this out, so any pointers will be greatly appreciated!

 

Thanks.

 

Frosty

5 Replies
Anonymous
Not applicable
Options
Galaxy S Phones

This is likely because your pictures and videos are not stored in those specific folders. Please check the MyFiles app to see what folders these files are in and then on your computer, navigate to the appropriate folders to see and transfer the files. 

userTQT3zGTEEL
Asteroid
Options
Galaxy S Phones

Thanks for the reply, but the MyFiles app says there is 6GB of data on the SD card and even shows 14 folders - including ones for Pictures and Vieos. BUT, when I click on those folders they don't show any pics / videos being in them...

 

(But the Pictures folder shows Camera Roll and Desktop App sub folders, but they too are empty!)

 

I can actually view and scroll the photos if I use the S8+ camera app, but the settings in that app don't allow me to do anything but select and/or delete.

 

In short, the photos and video footage seems to be on the SD card, but I just cannot find them!

 

Thanks.

 

Frosty 

0 Likes
Reply
Solution
Anonymous
Not applicable
Options
Galaxy S Phones

Was the USB driver for the device installed? You can find it here: Link

 

On the phone, once connected to the computer, drop the notification panel down and tab on the USB Connected As notification and then select File Transfer. 

userTQT3zGTEEL
Asteroid
Options
Galaxy S Phones

Hi

 

Well, I thought the USB driver was installed, but I downloaded your link and installed it just to be sure - and it seems to have solved the problem!

 

(All of the SD card files then showed up in the Win 10 file import app and I now have them saved on my PC at last!!)

 

Thank you very much for your assistance - I should have posted here before wasting hours of my time on this!

 

Much appreciated.

 

Frosty

 

0 Likes
Reply
ResQ176
Halo
Options
Galaxy S Phones

Have you tried putting the files in Google Drive, and then just downloading them on your computer?

0 Likes
Reply