JUMP TO SOLUTION Solved

Original topic:

Music stops playing when screen is off Galaxy S10 Plus

(Topic created: 03-22-2019 06:35 PM)
useraNJQZv8WIR
Cosmic Ray
Options
Galaxy S Phones

Hi, I am using an app from the Google Play store called Equalizer Plus and it seems to have huge bug on the Galaxy S10 Plus. I have the paid, full version of Equalizer Plus and it worked great on my old Galaxy S7. But now on my new Galaxy S10 Plus 1TB storage, 12GB ram(USA version with T-Mobile), I found a bug where the music pauses if the screen stays off for 2 mins. 

 
I was playing some mp3s with Equalizer Plus in my car, using the aux cable. The sound quality is amazing, but after about 2 mins, the player pauses and stays paused until you turn the screen on again. As long as you unlock the phone and keep the screen always on, the music will keep playing. But if you turn off the screen, or if the screen auto turns off, the music pauses forever until you turn the screen back on again. 
 
Just a few seconds before the pause bug happens, the music will stutter just so slightly for a fraction of a second.. then the full pause will happen.
 
If you tap the phone gently to reveal the fingerprint sensor on the black screen, the music will resume playing for roughly 6 seconds and then auto pause again as the screen goes back to black.
 
I have no other apps opened and nothing new installed. I tried closing all apps. I tried shutting down the phone and turning it back on again. I tried enabling and disabling Dolby Atmos. I tried both bit filtering modes built into the phone. But the bug is always there and always reproducible. 
 
For a reference test, I installed iheart Radio, played a radio station and turned off the screen. The bug never happens on iheart Radio. So I am certain it is just this Equalizer Plus app.
 
My theory is that this app is being auto shut off by Samsung OneUI or by Andriod 9 in an effort to save battery. I tried Medium, Optimized, and High Performance battery modes and the bug is always present in all 3 modes. I have Adaptive Power Saving disabled.
 
Please let me know how to fix this bug or let me know if you can fix it in the next update for the Galaxy S10 Plus.
 
The name of the app is Equalizer Plus. The company who makes it is MWM. It is available in the Google Play store. I have reached out to them as well to see if they have a fix. 
 
This bug happens when using the AUX cable into a car or home stereo. It also happens when you use wired headphones and even happens playing through the phone speakers with no wire plugged into the AUX jack. The bug also happens while plugged into USB power or running off the phone battery.
 
Thanks!
Jeremy Brack
 
 

1 Solution


Accepted Solutions
Solution
usergm5LIRVu2o
Constellation
Options
Galaxy S Phones

I found different settings for fixing this problem

 

Setttings > Apps > 3 dot menu > Special Access > Optimise Battery Usage

-- Turn this off for the app in question.

Setttings > Apps > 3 dot menu > Special Access > Allow app while Dagta saver on

-- Turn this on

 

I believe that the first one is the most important one, but I also modified the second.

 

 

View solution in context

16 Replies
useraNJQZv8WIR
Cosmic Ray
Options
Galaxy S Phones

Wow I found it!!! Thanks!!!!!!


This is how I fixed the problem:
Settings> Device Care> Battery...
 
Then scroll down to the app with the problem and click on it...
 
In my case, my app "Equalizer +" had the option "put app to sleep" enabled... 
 
So I disabled that and now it works great again!!! 🙂
 
THANKS!!!!!

I probably enabled it by mistake with my ear when I was last on a phone call 🙂 Sometimes when I am on a phone call, my ear or finger starts swiping the screen when I dont want it to and it can mess with the settings.
 
The other possibility is that the phone automatically decided to single out my music app for battery use since I use it a lot and decided that it would be best to "optimize" my music app by shutting it off when the screen is off! 🙂
 
Anyway, now I know how to fix it and it works great! 

I just wish we had a way to force the bottom nav bar to always be turned on in all apps and games, or individually.  Right now, its a mess with some games hiding the nav bar with a black bar and nothing inside it and other games going full screen, flooding to the edge. Both of those options force the user to swipe and then click. Used to be so easy to just press a physical home button. Another solution would be to re-map the Bixby button to "Home". Anyone know how to do that?
useruMPjvjD0yg
Astronaut
Options
Galaxy S Phones

Yup, settings>device care>battery>then the app> shut off "put app to sleep"

usergm5LIRVu2o
Constellation
Options
Galaxy S Phones

I am having the same trouble with my podcast app. The put app to sleep options is turned off, but it still keeps going to sleep.

 

0 Likes
userpBLYQvmBE5
Constellation
Options
Galaxy S Phones

This worked for me. Thanks!

0 Likes
madnonsense
Constellation
Options
Galaxy S Phones

This solution is the one to turn off the setting.  Why Samsung has this annoying feature in the first place? I play music on my wireless headset at work.  I thought my wireless headset ran out of battery.  But it was the phone that turns off the music after 2 minutes of "inactivity"

I'm using Samsung S10

0 Likes
Solution
usergm5LIRVu2o
Constellation
Options
Galaxy S Phones

I found different settings for fixing this problem

 

Setttings > Apps > 3 dot menu > Special Access > Optimise Battery Usage

-- Turn this off for the app in question.

Setttings > Apps > 3 dot menu > Special Access > Allow app while Dagta saver on

-- Turn this on

 

I believe that the first one is the most important one, but I also modified the second.

 

 

user4C6iTiTAu8
Constellation
Options
Galaxy S Phones

This did the trick for me!

0 Likes
user80uMySh2tL
Constellation
Options
Galaxy S Phones

Thanks! This fixed my issue of Spotify randomly stopping on lock screen.

userVnxY4bBO9M
Constellation
Options
Galaxy S Phones

Yaaasss!! Me too!! I kept thinking my Bluetooth earbuds were jacked up or my Spotify account was. Awesome!! 

0 Likes