Original topic:

Samsung Wallet strange pin behavior on S20+

(Topic created: 09-11-2023 02:38 PM)
Galaxy S Phones

I am trying to setup Samsung Wallet on S20+ and met a very strange problem.

I am at the screen of setting up PIN. When I touch a digit on the virtual number pad, all 4 digits slots are filled (apparently with the same digit). Then Wallet app responds with an error that PIN cannot have three digits with the same number.

I tried many times, press quickly, press slowly, but without success.

I finally get around that by quickly typing three digits, like 1,2,3 using both thumbs. Thought I have not idea what exactly the pin is. It could be 1123, 1223, or 1233. Since I have FP enabled so I am so worried about using Wallet.

I don't have the same problem on other place, like the 6 digits PIN to unlock screen. 

I am on the latest Samsung Wallet version 5.2.75

Has anyone met similar problem?

1 Reply
Community Manager
Community Manager
Galaxy S Phones

Hi there, welcome to the Community, and thanks for reaching out about this strange pin behavior on the Samsung Wallet app. I can see how annoying and potentially frustrating this can be. 

Have you tried uninstalling then reinstalling the application from Google Play or the Galaxy Store to see if the behavior continues? Have you tried clearing the cache and data on the app to see if this corrects it? This guide has the steps to do the latter: https://www.samsung.com/us/support/answer/ANS00077611/

If it is still doing the same thing after the troubleshooting, I recommend contacting the Samsung Wallet team by calling 1-844-726-7297. They can assist you in getting Wallet set up and working as intended with the pin.