JUMP TO SOLUTION Solved

Original topic:

Strange behaviour from phone audio when screen is asleep

(Topic created on: 8/17/20 4:52 AM)
useraPyN2aaxPJ
Constellation
Options
Galaxy S Phones

Hi Community! I have the Galaxy S10+ (2019).

 

When I play music from Spotify (for e.g. only, as the issue is across all apps), the music usually continues to play after the screen goes to sleep and the phone locks. However, over the past few months I've noticed on some occasions that, when the screen goes to sleep, the connection with Spotify seems to be very temperamental as the audio becomes very patchy, it will completely stop playing, then randomly continue the music after some time, then cut off again, etc. When it does cut off, if I double-tap the screen to wake it up, the music will continue again as normal straight away.

 

Also, when the phone is awake, songs don't play very smoothly. It feels like there might be a lot of background processes happening on the device which causes the music to very slightly skip/pause/flicker a bit. I've noticed the same kind of flickering during voice calls over data (WhatsApp/fb messenger, etc).

 

I'm wondering if anyone might have any troubleshooting tips for me?

 

Many thanks in advance!

1 Solution


Accepted Solutions
Solution
LongHiker
Samsung Care Ambassador
Options
Galaxy S Phones

It sounds like Spotify is being battery optimized. To change that:

 

  1. Long press on the Spotify icon
  2. Select App info
  3. Click on Battery
  4. If under "Optimize battery usage" it says "Optimizing battery usage", Spotify is being shut down to save battery. 
  5. Click Optimize battery usage
  6. Click the menu near the top and change from "Apps not optimized" to "All"
  7. Find Spotify and flip the switch to the left to turn off battery optimization. 

View solution in context

0 Likes
3 Replies
Solution
LongHiker
Samsung Care Ambassador
Options
Galaxy S Phones

It sounds like Spotify is being battery optimized. To change that:

 

  1. Long press on the Spotify icon
  2. Select App info
  3. Click on Battery
  4. If under "Optimize battery usage" it says "Optimizing battery usage", Spotify is being shut down to save battery. 
  5. Click Optimize battery usage
  6. Click the menu near the top and change from "Apps not optimized" to "All"
  7. Find Spotify and flip the switch to the left to turn off battery optimization. 

View solution in context

0 Likes
useraPyN2aaxPJ
Constellation
Options
Galaxy S Phones

Thank you so much!

 

I just followed your advice, and the problem appears to have gone.

 

You are the best!

0 Likes
LongHiker
Samsung Care Ambassador
Options
Galaxy S Phones

@useraPyN2aaxPJ That's great news! Glad that I could help. 

0 Likes