JUMP TO SOLUTION Solved

Original topic:

How can I stop incoming calls from interrupting my music?

(Topic created: 10-28-2022 04:34 AM)
Simple-Needs
Asteroid
Options
Galaxy S20

As is incoming calls interrupt my music streaming and playback. 
This is independent of:

  1. Focus Mode
  2. Do not Disturb Mode without exceptions
  3. Calls muted and without vibration
  4. Separate app sound for e.g. Soundcloud or Spotify (Also: Is there a real reason why this feature is limited to 5 Apps?)

Following work-arounds also don't work:

  1. Airplane Mode doesn't work as it apparently does not allow to activate mobile data for some reason.
  2. Under SIM connections I found no possibility to specifically deactivate calls
  3. The call settings provide no possibility to
    1. block all calls irrespective of caller id
    2. call barring; it just states "Failed to read data\nCall barring rejected."

 

In the current state the Samsung Galaxy S20 Plus is effectively unusable as media player. while e.g. jogging as you constantly have to manually reject calls.

I never had such a problem with devices from e.g. Xiaomi

This is a very disapointing experience especially considering the high price of Samsung devices.

Please provide a solution.

1 Solution


Accepted Solutions
Solution
user751201tmO21
Honored Contributor
Options
Galaxy S20
If I absolutely do not want to hear the phone to ring, I simply Forward All Calls to my Google Voice number

View solution in context

11 Replies
Oxford
Black Hole
Options
Galaxy S20
Go back to Xiaomi? Just askin...
0 Likes
Simple-Needs
Asteroid
Options
Galaxy S20

Thanks, Harvard!

That is an interesting suggestion. A little bit unwieldy as there are a couple of hundred bucks locked in this product.

How about we first have a look if there is an easier solution? Maybe even something software-based? 🙂


0 Likes
Yamialex224
Neutron Star
Options
Galaxy S20
Samsung is a different manufacturer so odds are you can't
Don't get mad cause you don't like someone's answer
Any phone I had whatever media was playing was lowered wheb a call came in
0 Likes
Simple-Needs
Asteroid
Options
Galaxy S20

Hi Yamialex224,

thank you for supporting by stating your anecdotal experience and opinion that there probably is no fix. It's a bit sad to be honest, I have been able to not be disturbed by calls on every other handset I had until now. 

Best regards and have a great weekend

Simple-Needs

0 Likes
Yamialex224
Neutron Star
Options
Galaxy S20
Like I said samsung is different. If you don't want the issue switch to a new phone that's the only advice you will gey
0 Likes
Options
Galaxy S20
The only way I know of would be Do Not DisturbScreenshot_20221028_095843_Settings_1000014863_1666965524.jpg
0 Likes
Simple-Needs
Asteroid
Options
Galaxy S20

Hey ButtaBean_420,

thanks for your proposal, with what settings?

I tried it with 

nse-1525506180521423020-1000000970.jpg

unnamed.jpg

When I then call myself from another phone, my S20 shows no notification of the call but still stops the music. 🤐

 

Thanks so much! Have a great weekend!

Best

Simple-Needs

0 Likes
Solution
user751201tmO21
Honored Contributor
Options
Galaxy S20
If I absolutely do not want to hear the phone to ring, I simply Forward All Calls to my Google Voice number
Simple-Needs
Asteroid
Options
Galaxy S20

Have a splendid weekend!

Best

Simple-Needs