JUMP TO SOLUTION Solved

Original topic:

S21 - Ready to connect when network quality improves

(Topic created: 04-12-2022 10:54 AM)
4622 Views
uservAWH6lOIjh
Constellation
Options
Galaxy S21

Hello, recently (a month, perhaps) I've been plagued with my phone switching from WiFi to cell data with the message "Ready to connect when network quality improves".  Not sure why the switch all of a sudden.

I notice it most at home and the office, which is where I spend the most time.  I work from home and I get this message when all normal devices are connected to the internet and are functioning normally.  I ask other family members if their iPhones are connected to WiFi and they note no issues.  I am also getting this problem in the office where there are no other issues noted.

Is there any way for me to diagnose what is causing this, or any particular settings I should adjust?  I did perform a Google search and most results speak to changing the settings at the router but surely it's not the fault of all other routers and my phone is "perfect"?  Thoughts?

0 Likes
Reply

1 Solution


Accepted Solutions
Solution
bill-e
Epic Samsung Care Ambassador
Options
Galaxy S21

Go to Settings->Connections->Wifi->3 Dot menu-> Advanced->Toggle off "Switch to mobile data"

** If my response helps, please click on Like (Heart). If I resolved your issue also please click on Accept as a Solution so that others can benefit.

Bill
---
Galaxy Fold 5 512g(VZW), Galaxy Book (original, VZW), Tab S8 Ultra, Tab S4, Galaxy Watch6Classic 47mm(VZW), Galaxy Watch5Pro(VZW), M8 Smart Monitor, NEO 55" QN90D TV

View solution in context

3 Replies
Solution
bill-e
Epic Samsung Care Ambassador
Options
Galaxy S21

Go to Settings->Connections->Wifi->3 Dot menu-> Advanced->Toggle off "Switch to mobile data"

** If my response helps, please click on Like (Heart). If I resolved your issue also please click on Accept as a Solution so that others can benefit.

Bill
---
Galaxy Fold 5 512g(VZW), Galaxy Book (original, VZW), Tab S8 Ultra, Tab S4, Galaxy Watch6Classic 47mm(VZW), Galaxy Watch5Pro(VZW), M8 Smart Monitor, NEO 55" QN90D TV
rphilly333
Astronaut
Options
Galaxy S21
I'm having the same issue. Got a new s22+ and the same coffee shop I've been coming to daily to use wifi is giving me this message. It connects me...but only lasts a short time and then I'm back to 5g. I've looked for the above solution but don't have that on my phone. Please help. My crappy A03 never had this issue.
0 Likes
Reply
bill-e
Epic Samsung Care Ambassador
Options
Galaxy S21

Those instructions were for Android 12.  For Android 13, Go to Settings->Connections->Wifi->3 Dot menu->Intelligent WiFi->Toggle off "Switch to mobile data"

 

 
** If my response helps, please click on Like (Heart). If I resolved your issue also please click on Accept as a Solution so that others can benefit.

Bill
---
Galaxy Fold 5 512g(VZW), Galaxy Book (original, VZW), Tab S8 Ultra, Tab S4, Galaxy Watch6Classic 47mm(VZW), Galaxy Watch5Pro(VZW), M8 Smart Monitor, NEO 55" QN90D TV