Original topic:

Block Unknown Numbers Not Working

(Topic created: 01-18-2023 01:08 PM)
djHaystack
Astronaut
Options
Galaxy S22
I've done power cycle, factory reset, and even changed carriers. My phone rings for any number whether in my contacts or not.
0 Likes
10 Replies
Rydah
Samsung Care Ambassador
Options
Galaxy S22

Hey there @djHaystack, I hope you're doing well.

I assume you're talking about the Block calls from unknown numbers feature that is in the phone app (Phone>Menu>Settings>Block numbers>Block calls from unknown numbers)

Have you tried turning the setting off and then back on? If that doesn't work, I'd recommend clearing the Phone app's data. This will clear the phone app's settings but this may also resolve your issue. You can do this by going to Settings>Apps>Phone>Storage>Clear data.

Hope this helps!

 

 

Best regards,
Rydah
Samsung Care Ambassador

If you've found my post to be helpful, please like the post. If my response resolved your issue, please press the "✓ Accept as Solution" button.
djHaystack
Astronaut
Options
Galaxy S22
I've done this but please note my original post indicating I have done a factory reset on the phone and it still isn't working. "Unknown" means any call not from my contacts, correct?
0 Likes
Rydah
Samsung Care Ambassador
Options
Galaxy S22

Sorry for missing that piece of detail.

No, the Block calls from unknown numbers feature does just that, blocks calls from "Unknown" numbers as in callers who have chosen to hide or mask their caller ID. If you are wanting to block calls from numbers that are not in your contacts, your best option would be Do Not Disturb mode. Create a DND rule and allow calls and texts from contacts only and enable notifications.

I hope this clarifies and helps!

 

 

Best regards,
Rydah
Samsung Care Ambassador

If you've found my post to be helpful, please like the post. If my response resolved your issue, please press the "✓ Accept as Solution" button.
djHaystack
Astronaut
Options
Galaxy S22
Okay I misunderstood it's intended use. I use DND for sleep.
0 Likes
Rydah
Samsung Care Ambassador
Options
Galaxy S22

Understandable.

You can create a separate DND schedule for the day that allows calls/text notifications from contacts. This should help.

 

 

Best regards,
Rydah
Samsung Care Ambassador

If you've found my post to be helpful, please like the post. If my response resolved your issue, please press the "✓ Accept as Solution" button.
djHaystack
Astronaut
Options
Galaxy S22
But unfortunately the allow list is global, not per schedule. I want to allow all contacts but during sleep only my favorites. It's this possible?
0 Likes
Rydah
Samsung Care Ambassador
Options
Galaxy S22
It's definitely possible. Just create a separate scheduled DND occurrence in the DND settings. Please see the example in the screenshot.Screenshot_20230118_155755_Settings_1000006012_1674086275.png

Best regards,
Rydah
Samsung Care Ambassador

If you've found my post to be helpful, please like the post. If my response resolved your issue, please press the "✓ Accept as Solution" button.
djHaystack
Astronaut
Options
Galaxy S22
But the allow list isn't scheduled so I would have to manually update it.....
0 Likes
Rydah
Samsung Care Ambassador
Options
Galaxy S22

Wow, I see. There is room for some improvement on this front. Being able to adjust the allow list per schedule sounds most logical.

@Samsung_Moderator, can you please flag this post as a feature suggestion for the development team? When creating Do Not Disturb schedules, there is no way to change the allowed list per schedule.

 

 

Best regards,
Rydah
Samsung Care Ambassador

If you've found my post to be helpful, please like the post. If my response resolved your issue, please press the "✓ Accept as Solution" button.