Original topic:

Recently Added Contacts not Appearing

(Topic created: 10-22-2023 02:39 AM)
Galaxy S22

Hello everyone, I know that by phone/contacts app is supposed to show recently added contacts at the top of the list. My phone (S22 Ultra) simply doesn't do this. Which has been very inconvenient for me on multiple occasions.

Any Idea why this is happening or how I can fix it?

Thanks so much in advance to anyone who reads and replies!

3 Replies
Galaxy S22
Hi there! I may be able to help. To confirm, you are talking about adding a brand new contact and not updating a pre-existing one right?

If you are are trying to add a brand new contact:
There are two ways to do this, through the "Phone" app or through the "Contacts" app. They are not the same app and only the "Contacts" app will "show recently added contacts" like you want. Below are the steps to see recently added contacts:

#1. Search for and open the "Contacts" app on your device. (DO NOT open the "Phone" app and go to the contacts section).

#2. Once you have opened the "Contacts" app, click on the + icon located in the top right of the screen. (See picture 1 where the + icon is circled in yellow).

#3. You should now be on the screen where you can enter your new contact's name and telephone number. Enter at least these two fields before you click the save button. ***NOTE: before you enter the new contact name and phone number, look at the top of the contact entry page and make sure you are saving the contact the way you want to. In the 2nd picture I have attached, you can see my entry for my new contact will be saved to my Gmail account. You can change where you want this contact to be saved by clicking on the down arrow to the left of, in my case, the Gmail email address. This will give you the option to save to a different Gmail account, your Samsung account, your phone, or your Samsung account.** (Personally, I prefer to save all contacts to the same Gmail account so when I get a new phone all my contacts will transfer over seamlessly. Except if you get an iPhone next which you just shouldn't).

#4. After you have clicked the save button, the next screen will show your newly added contact with all the information you entered. (Screen shown in Picture 3).

#5. From this screen, click the back arrow located at the top left of the screen. (Picture 3).

#6. Once you click the back arrow from the previous step, you will be taken to your main "Contacts" screen. You should now see a category titled "Recently added".
This category may be underneath your profile category and above your favorites category if you have these categories enabled. (Refer to Picture 4 highlighted section).

***Now here's the catch: after completing the above steps and getting your "Recently added" category with your new contact displayed underneath, this new "Recently added" category and contact will disappear the moment you close or exit out of the Contacts app. I know, it's extremely inefficient and quite annoying.

**Pro tip: once you save your new contact using the "Contact" app and following all steps above, when you get to the last step where you see the new "Recently added" category and contact:
Select the contact and briefly call them then hang up. Doing this will keep them at the top of your "Recents" list.

You can also choose a group to associate this new contact with when you are entering or editing their contact information for easily finding them. You could also choose to favorite them which will keep them at the top of your Contacts list always.

I hope this helps! Grateful for your avatar :peace_symbol:Screenshot_20230413_131210_Contacts_1000013463_1681409530.jpgScreenshot_20230413_131601_Contacts_1000013465_1681409761.jpgScreenshot_20230413_132800_Contacts_1000013469_1681410480.jpgScreenshot_20230413_132936_Contacts_1000013471_1681410576.jpg
Galaxy S22
So basically there is no way to display recently added for more than one instance and not the next day or so?
Contact app other than Samsung's seems to be the only answer.
Galaxy S22