Original topic:

S23 FE Endless WiFi Woes - Is there workaround or a solution in sight to the constant drops?

(Topic created: 04-12-2024 12:30 PM)
1050 Views
AppleFritter
Cosmic Ray
Options
Galaxy S23

I upgraded from a S20 FE to an S23 FE (unlocked) in Jan 2024 from the Samsung US online store. Since the beginning, it's been plagued with the problem of not staying connected to the WiFi at all. However I didn't realize that until the ATT cellphone bill came in a couple of weeks later indicating I'd exceeded the data usage quota. The phone had been using mobile data even when I was at home. Since then I've been manually turning off mobile data each day at home. But its not just home - it won't stay stably connected to WiFi anywhere - stores, doctor's office, malls, Comcast Xfinity network, ATT hotspots, airports, even outside the US at hotels/airbnbs. I've tried them all and it doesn't change behavior. The phone keeps connecting and disconnecting in loops like waves. So I open an app or page, its a constant switch of loading, to "oops, no network" over and over again.

I've read the forum posts here, the ones on reddit and others  - disabled intelligent wifi, set static IP, split the network (2.5 GHz vs 5 GHz) on the home router, turned off bluetooth, refreshed WiFi using the *# sequence, disconnected other devices from home network,  to see if anything fixes it. No dice. For the past 72 hours its been the worst because it doesn't stay connected for more than a minute and most times tries connecting but doesn't succeed. Can't use my smartphone for anything build old fashioned text messages and phone calls anymore. I've restarted the router, restarted the phone with no luck and its driving me batty with the constant disconnects since I can't even get to my Wifi Management app (ATT Smart home) without it. Today I found a post on the Samsung EU forum about disabling WiFi 6 on routers or setting a fixed channel for the 5 GHz network. I could google to find instructions and do it, but would that really change the fact that my phone won't stay stably connected to a WiFi network elsewhere? I find it hard to believe that it is the routers everywhere that are the problem rather than the device.

I have multiple other devices at home including iOS, Windows and Android (Samsung M33) that don't seem to have a problem except mine. Been a Samsung Galaxy device user for over a decade and half but at this point I'm considering trading it in for another device by a different manufacturer entirely because this is beyond frustrating. 

Is there anything I have not tried that I should before giving up and getting another device? 

16 Replies
xFridgeWizardx
Asteroid
Options
Galaxy S23

This seems to be a channel issue with 5GHz WIFI.  If you change your 5GHz wifi channel on your wireless router to above 140, it resolves the issues.  If you need help with that let me know!

Hope this helps!

AppleFritter
Cosmic Ray
Options
Galaxy S23

Thanks, l think I know where to change it’s , so let me try that. I changed the WiFi SSID of 2.5 and 5 GHz on my router making them visible as 2 different networks to see if the mobile is more stably connected to any one of them. 

My5 GHz is currently set to 80 and 2.5 GHz is set to lower (20 I think). I’ll update the 5 GHz to higher and see if that helps.

Question though - Do you think this change in channel to above 140 might help it stay connected to just the 5 GHz network or it’ll make a difference to the 2.5GHz as well? My router only allows me to choose from 3 available static options (drop down) so I cant set it to another custom value 

0 Likes
AppleFritter
Cosmic Ray
Options
Galaxy S23

Checked this and I was mistaken - I can’t change the channel manually. For reference, I have an ATT provided BGW320-505 router which has channel selection set to automatic and is unchangeable. So all I can do is “Find best 5 GHz channel” which I tried and it latches onto channels 36 and 149 both of which correspond to 80 MHz. I can’t update this to be any higher. In case of my 2.5 GHz network, when I “Find best 2.5 GHz channel” it latches onto channel 1 which corresponds to  20 MHz.

Another dead end unfortunately.

0 Likes
xFridgeWizardx
Asteroid
Options
Galaxy S23
The 80 MHz is your channel range. I'd recommend keeping that. Set it to 149 which should be the mid point of the range.

In answer to your question. The s23FE will work without issue on 2.4 GHz wifi without issue, it's the 5 GHz that's the issue with the phone.

To get a visual of the wifi networks, you can download an app on you phone called Ping Tools Pro on android. You can go to the wifi scanner and see where the networks are sitting on a graph for both 2.4 and 5 GHz.
0 Likes
AppleFritter
Cosmic Ray
Options
Galaxy S23

That's the thing though, I cannot set it to 149 at all. I'm not allowed to upload a screenshot of the WiFi settings from my router, or I would to show what I mean.

Also, I know you said S23FE will work without issue on the 2.5 GHz WiFi, but my phone does not consistently connect and stay on the 2.5 GHz network either. Most of my the other devices are on the 5 GHz WiFi, so it isn't congestion as far as I can tell. For several hours (most days) now, its been ping ponging attempting to connect to the 2.5 GHz then failing, trying 5 GHz and failing, trying 2.5 GHz again in an endless cycle.

Yesterday, I enabled the connectivity lab setting under WiFi on my phone and from the history of WiFi connections I see ASSOC_REJECT plenty of times, but it appears for both the 2.5 GHz and the 5GHz. I don't understand the details in there enough to know what to make of that though. I'll check out the Ping Tools Pro app you've mentioned. Thanks for the additional ideas.

0 Likes
xFridgeWizardx
Asteroid
Options
Galaxy S23
No worries. If you're having issues with the router settings I'd recommend you reach out to AT&T who gave you the modem / router.
0 Likes
AppleFritter
Cosmic Ray
Options
Galaxy S23

Update: I've put my ATT router in passthrough mode and am using an Eero as the router instead. Hasn't changed the phone's behavior in terms of dropping and reconnecting to the WiFi broadcast by the Eero, but it does stay on a little bit longer once it connects before going through the whole cycle all over again. Outside of home, status quo - I can't use any WiFi still, have to switch to mobile data if I want to open any app or website or use VoIP features.

0 Likes
AppleFritter
Cosmic Ray
Options
Galaxy S23

Update 2: Been on the "new" router for 5 days now. Has not made a difference to device behavior. It still keeps looping between connecting and disconnecting to WiFi all day. I have to turn on mobile data to have any stability at all for using apps or to browse for anything. A Samsung security update was pushed out yesterday (18 Apr 24) evening EST hours and I did not let it use my mobile data for that. So that took over 2.5 hours to finish up with the constant WiFi drops - downloading the update in bits and pieces, pausing while it kept losing WiFi connection. I'm on the lookout for an alternate device that is more reliable than this.

I've also enabled the Connectivity Labs and set it to display the band under the available WiFi networks and I can clearly see it when it switches between the 2.5 GHz and 5 GHz  in the same WiFi network - without having stable connection on either. This is after disabling all but one setting(Show network quality info) in the "Intelligent WiFi" options. This is not a router issue - this is a very clearly device issue - software/firmware or hardware, I do not know. 

0 Likes
merbst
Astronaut
Options
Galaxy S23
I had a similar issue on my Tab S9+ that started when I installed DuckDuckGo Browser's built in tracker blocking firewall, which installs itself as a VPN, which they admita is a mislabeling, but it was my fault that I misconfigured by turning both Settings 》 More Connections 》 VPNs 》 DuckDuckGo Tracker blocking to enable the Always On setting (Which is as suggested), however the "block all other traffic" setting should be off.
When it was on it behaved like you described!