JUMP TO SOLUTION Solved

Original topic:

Disable notifications for Health on Watch 5 Pro?

(Topic created: 09-29-2023 06:24 AM)
6543 Views
CaptPackrat
Cosmic Ray
Options
Galaxy Watch
I'm really getting tired of the useless notifications like "you're on your way" and "completed 1 of 3 goals". Is there a way to disable individual messages (I'd like to get one saying I completed my goals for the day and nothing else), or else turn them all off?

I have them switched off in the Wearable app on the phone, but the watch seems to be ignoring that setting. The only settings I can find for notifications on the watch just refer me to the phone app.

I've got the latest version of the firmware, which I really wish I hadn't installed.

1 Solution


Accepted Solutions
Solution
da1em
Astronaut
Options
Galaxy Watch

On your watch, go to Settings -> About Watch -> Software Information

Tap on the Software Version 5 times to enable developer mode.

Go back to the main Settings page -> Developer Options -> App Notifications -> All Watch Apps

Scroll down to Samsung Health, tap on it, and disable wear_notification_daily_activity!

 

(All borrowed from CasualContentYT on Reddit)

View solution in context

9 Replies
JBTechfanatic
Black Hole
Options
Galaxy Watch
In the Wear app first go into app notifications and disable whatever you do not want to be notified about including the health system also shut off automatic workout detectionScreenshot_20230929_094614_Galaxy Watch6 Manager.jpgScreenshot_20230929_094642_Samsung Health.jpg
0 Likes
Reply
CaptPackrat
Cosmic Ray
Options
Galaxy Watch
Notifications were turned off for Health Platform, Samsung Health, and Samsung Health Monitor, and automatic workout detection was also disabled. I'm still getting the notifications anyway.
0 Likes
Reply
CaptPackrat
Cosmic Ray
Options
Galaxy Watch
I think I figured out what the problem was. I toggled the notifications on and then back off again and I haven't gotten any notifications since. I'm guessing that when I upgraded to the newest firmware, it switched notifications back on but didn't change the settings in the Wearable app, so it looked like they were off when they really weren't.
0 Likes
Reply
ctretyak
Constellation
Options
Galaxy Watch

I have the same problem. Every day I get notifications about my goals. I don't know how to disable only this without disabling all notifications from Samsung Health. Please help!

ctretyak_0-1702298423364.png

 

JHolland
Constellation
Options
Galaxy Watch

This is driving me crazy as well. I've searched everywhere to disable "You've reached your goals" or "Well done" notifications. What a waste of time/energy! As @CaptPackrat suggested on 10/2, I toggled the notification switches on and then off. I've restarted both my phone and watch and we'll see if that works.

0 Likes
Reply
Solution
da1em
Astronaut
Options
Galaxy Watch

On your watch, go to Settings -> About Watch -> Software Information

Tap on the Software Version 5 times to enable developer mode.

Go back to the main Settings page -> Developer Options -> App Notifications -> All Watch Apps

Scroll down to Samsung Health, tap on it, and disable wear_notification_daily_activity!

 

(All borrowed from CasualContentYT on Reddit)

billc_ia
Halo
Options
Galaxy Watch

Thanks for the tip. Tried this, but for me (GWC 5 Pro), all options were on, but greyed out and not selectable.

Gck105
Asteroid
Options
Galaxy Watch

Amazing that this isn't doable without going into developer mode! Thanks! 

Dragon Mama
Constellation
Options
Galaxy Watch
Thank you so much!
0 Likes
Reply