JUMP TO SOLUTION Solved

Original topic:

Samsung odyssey g70b 32' 144hz monitor switches from 144hz to 60hz until restart

(Topic created: 05-05-2024 11:23 AM)
868 Views
gromnomnom
Asteroid
Options
Monitors and Memory

I bought a Samsung odyssey g70b 32' 144hz monitor last month and randomly it will switch from 144hz to 60hz, and only show options for refresh rates lower than 60hz until i restart my computer.

1 Solution


Accepted Solutions
Solution
Samsung_Moderator
Community Manager
Community Manager
Options
Monitors and Memory

I would recommend turning off game mode completely to see if this helps. Also, after looking around I was seeing other people have this issue but on a laptop and not on a Samsung based device this seems to be a some type of windows issue causing this to happen. From what I could find changing the power plan to performance should help. If it does not, I would recommend to also reach out to Microsoft support.

View solution in context

4 Replies
SamsungJustin
Community Manager
Community Manager
Options
Monitors and Memory

Hello, There. The hz the monitor shows is dependent on your external device's signal. The monitor only displays the signal received from whatever is connected to it.  (i.e. Computer, roku, cable box, etc.)  

 

I would recommend checking your computer or any external devices you may have connected to the unit. You'll need to check those settings, along with your graphics card, and make sure everything is up to date software-wise with your external device.  Here's a link that can help: https://www.samsung.com/us/support/answer/ANS00085242 

In addition, you can also check that the software is completely up to date on your unit by utilizing the following steps: https://www.samsung.com/us/support/answer/ANS00062224/ 

0 Likes
Reply
gromnomnom
Asteroid
Options
Monitors and Memory

Everything is up to date on both my computer and the monitor. It seems to happen after the monitor goes to sleep and wakes up. Switching Game Mode off and on also seems to help.

0 Likes
Reply
Solution
Samsung_Moderator
Community Manager
Community Manager
Options
Monitors and Memory

I would recommend turning off game mode completely to see if this helps. Also, after looking around I was seeing other people have this issue but on a laptop and not on a Samsung based device this seems to be a some type of windows issue causing this to happen. From what I could find changing the power plan to performance should help. If it does not, I would recommend to also reach out to Microsoft support.

gromnomnom
Asteroid
Options
Monitors and Memory

If i turn off game mode the highest refresh rate I'm able to use is 120hz. My power plan is set to performance. I think this is a Samsung issues, my other monitor has no problems like this. I'm wondering if there is a way to set a hotkey on the remote to toggle game mode on and off to save me from going through the menu everytime this happens because I don't see it being fixed.

0 Likes
Reply