JUMP TO SOLUTION Solved

Original topic:

Call & text on other devices requires “Reset network settings” every other day

(Topic created: 05-08-2021 01:39 PM)
Dan5678
Cosmic Ray
Options
Tablets

My Wi-Fi only S7+ will send and receive SMS text messages for a day or two. Then, when I send a message, it spins for a while and eventually gives the error: Couldn't send message.

The only fix is to perform a "Reset network settings" on my S20 FE 5G cellphone.

Is there an easier or permanent fix? Resetting network settings causes me to lose my Wi-Fi settings, and my Bluetooth connections to my watch and my car.

I have tried all of the following when the error occurs. None of them worked.

     Wipe entire cache partition on S7+.

     Turn "Call & text on other devices" off and back on for both S20 and S7+.

     Reset Network Settings on S7+.

     Restart S20 and S7+.

     Wipe cache and data on S7+ Messages app.

     Turn off Battery Optimization for "Call & text on other devices" and "Messages" for both.

     Clear the cache on the Samsung Messages app on S20 and S7+.

Any suggestions greatly appreciated.

Dan

0 Likes

1 Solution


Accepted Solutions
Solution
Dan5678
Cosmic Ray
Options
Tablets

I believe I have found the solution to the problem. At least it has worked for a couple of days now.

The "Call & text on other devices" app on a tablet doesn't show up in the list of Apps. So, you can't initialize it by Clear Cache, Clear Data, Disable, or Uninstall Updates.

In the past, on the tablet, I have turned the "Call & text on other devices" feature off and on many times and it didn't help. However,  a couple of days ago, I turned off the Messages button underneath the "Call & text on other devices" before turning off "Call &  text on other devices". That seemed to cause the app on the tablet to re-initialize because for the first time, when I was turning everything back on, it gave me the message  on the tablet: "To continue, Agree to the Privacy Notice". This appears to have solved the problem.

The full procedure I went through was:

  • Tablet > Settings > Advanced features > Call & text on other devices > Messages > Off
  • Tablet > Settings > Advanced features > Call & text on other devices > Off
  • Cellphone > Settings > Advanced features > Call & text on other devices > hold down tablet name > Remove
  • Cellphone > Settings > Advanced features > Call & text on other devices > Off
  • Wait 10 seconds
  • Cellphone > Settings > Advanced features > Call & text on other devices > On
  • Tablet > Settings > Advanced features > Call & text on other devices > On
  • Click Agree on tablet for "To continue, Agree to the Privacy Notice".

View solution in context

30 Replies
ShowiestOdin
Explorer
Options
Tablets
Try this: Reset your phone then immediately turned the power off on your phone and leave it off for at least 15 minutes. Power phone back on and see how it is. Hope this helps.
0 Likes
Dan5678
Cosmic Ray
Options
Tablets

Thanks for replying. When you say Reset the phone, do you mean Reset network settings?

0 Likes
ShowiestOdin
Explorer
Options
Tablets
Just hold your power button and three icons will come up, power off, restart and emergency off. Choose first the restart option your phone will turn off then turn back on I'll by itself. Next you will want to press and hold the power button again this time choose the power off option or icon and leave your phone off for at least 15 minutes. Then turn it back on manually you'll have to press and hold the power button until the phone comes back on then see how things are. Hope that works, let me know if you want.
0 Likes
Dan5678
Cosmic Ray
Options
Tablets

I tried that and it didn't help. Any other suggestions?

0 Likes
ShowiestOdin
Explorer
Options
Tablets
Reboot your router do you know how?
0 Likes
Dan5678
Cosmic Ray
Options
Tablets

I know how. I rebooted it a week ago and it didn't help.

0 Likes
ShowiestOdin
Explorer
Options
Tablets
Did you add a new phone or what changed when you first noticed the text messages glitch,
0 Likes
Dan5678
Cosmic Ray
Options
Tablets
I think it has been doing this since I purchased the tablet.
0 Likes
Dan5678
Cosmic Ray
Options
Tablets
For months.
0 Likes