JUMP TO SOLUTION Solved

Original topic:

Google calendar instead of Samsung Calendar

(Topic created: 07-08-2022 08:52 AM)
usersHcX6fH38O
Asteroid
Options
Tablets

Hello,

I have a new Galaxy S6 Lite that has been received the Samsung upgrade to Android 12.

I want to use Google Calendar instead of Samsung Calendar because my company uses the entire Google Workspace suite, and I'd like to use the Google tools for the appropriate modules in the suite (GMail, Google Calendar and so on).

The system will not allow me to turn on Alarms and Reminders for Google Calendar and Google Calendar won't open without turning them on.  When I start Google Calendar I get to a screen that says, "Google Calendar requires your permission to set reminders.  GO TO SETTINGS"  I follow the link to settings and it takes me to Alarms and Reminders where Google Calendar is off and Samsung Calendar is on.

I cannot turn on Google Calendar Alarms and Reminders on this screen.  I can turn off and on Samsung Calendar, but not Google Calendar.

I don't believe this to be an issue with Google Calendar, but instead an issue with the way Samsung has configured the device to force Samsung Calendar to be used.

I can't disable or uninstall Samsung Calendar without rooting my device, which I don't want to do--it's not out of warranty, and every time I've rooted an Android device it's become unstable.

I've tried turning off the Alarm and Reminders setting for Samsung Calendar, force stopping Samsung Calendar and clearing its storage first, and then tried to turn on the Alarm and Reminders for Google Calendars, and I still cannot do it.  I press the slider, and it flashes, but stays off.  Something in the system is stopping me from enabling Alarms and Reminders on Google Calendar.

Is there any way to set Google Calendar as my default calendar and turn on Alarms and Notifications on a Galaxy S6 Lite?

0 Likes

1 Solution


Accepted Solutions
Solution
usersHcX6fH38O
Asteroid
Options
Tablets

Apparently it gets fixed when you add a second Google account.  I wanted to sign into my Samsung account with my personal Google account, so I added it in settings, and then Google calendar opened without a problem.  And when I check Alarms and Reminders, Google Calendar is on and Samsung Calendar is on.

View solution in context

0 Likes
1 Reply
Solution
usersHcX6fH38O
Asteroid
Options
Tablets

Apparently it gets fixed when you add a second Google account.  I wanted to sign into my Samsung account with my personal Google account, so I added it in settings, and then Google calendar opened without a problem.  And when I check Alarms and Reminders, Google Calendar is on and Samsung Calendar is on.

0 Likes