JUMP TO SOLUTION Solved

Original topic:

Galaxy S8 Wifi Issues

(Topic created on: 5/19/17 12:39 PM)
Holybob
Asteroid
Options
Galaxy S Phones

So I am posting here because after research I do not see anyone with this issue and wanted to see if anyone had suggestions on what to do to attempt to fix it. 

 

What will happen is my phone will lose internet connection while connected to my Wifi. As shown in the screen shots below it has the Wifi Symbol along with an exclamation mark. When I go to the Wifi settings it states "Internet may not be available"

 

The only way to fix the issue is to turn the wifi off then back on. Now keep in mind that this does not happen all the time as It will happen spoardically throughout the day and there does not seem to be a specific app that causes this. This has happened while browsing the internet on multiple different browsers and it has happened while watching videos in applications such as Youtube, Twitch, Netflix, Hulu, etc.... This issue only seems to be affecting my galaxy S8 as the other devices on my network does not have this issue including my old Samsung S7 Edge.

 

What I have tried is the following in no particular order 

  • Turned the phone off/on
  • Cleared browser cache
  • Cleared the cache partition
  • Reset my wifi connections
  • Factory reset my phone
  • Reset my router
  • Verified my Router Firmware was up to date
  • Had Verizion send me a replacement phone. Same issue happens

My Router is the Google Onhub

 

Galaxy S8 Screen Shot 1.pngGalaxy S8 Screen Shot 2.png

JUMP TO SOLUTION
477 Replies
S8manager
Constellation
Options
Galaxy S Phones

Nope. Facing same issue again.

 

0 Likes
Husl4it
Constellation
Options
Galaxy S Phones
turn off smart network connect, should fix problem
0 Likes
JeffSh
Constellation
Options
Galaxy S Phones

Having same issues with ATT Galaxy S8 Active.   Connected to Netgear ORBI routers in house.   It's been happening quite allot lately - daily.  I have to turn WIFI off and then on for the phone and then it connects - else "WIFI Authenetication Error".   No other cell phones in my house are havinging this issue... iphones, and S7 active.

I just removed the ATT WIFI app - will see if that helps at all.

0 Likes
userNB3Vh8KK0N
Constellation
Options
Galaxy S Phones

Had issue with samsung earlier product with regard to wifi connection with netgear router (authentication error show up on my old samsung smartphone once every month). With newer version of smartphone, the problem became unbearable. I was unable to connect to wifi all together.

 

Approach: 1). Logon into NETGEAR Router, and in security options, pick "Disable". I was able to connect my new samsung smartphone to my wifi network. Old setting was "WPA-PSK".

2). Now play around with the setting. Instead of choosing "Disable", choose "WEP", and generate a key. It connected as well.

 

So the problem lies with old primitive security setting of "WPA-PSK" protocal and newer password encryption procedure in the newer device. At least in my case, it fixed the problem.

 

Hope this could be helpful

0 Likes
userEjt6pDls4q
Astronaut
Options
Galaxy S Phones

I have a Galaxy S6 and a Galaxy S8.  Same internet that we've had for years, same router, same everything.  All of a sudden my S8 is giving me the wifi symbol with the exclamation point, and telling me that "internet connection may not be available" but all of my other household devices using the same wifi are working fine and not losing connection.  I have shut down and restarted my phone umpteen times.  I have reset my network connections twice.  I have shut down and restarted my modem and router multiple times.  I have gone to the advanced settings and have told it to connect to wifi automatically.  I have told my phone to "forget" my wifi connection and try resetting it with the password several times.  This should not even be an issue.  I shouldn't have to assign a static IP to my phone.  I shouldnt have to reset a DHCP or other settings on my router.  My phone is a "smart phone" and should know what it needs to do to work correctly on my home wifi network.  The only conselation is that my data is not being used, and other than the wifi symbol and exclamation point and a slow response time, the wifi does seem to work.  It is just extremely frustrating that there was no issue until recently, and now my OCD is driving me bananas knowing that my connection may or may not be working.  I have no problems with wifi connection anywhere else that I use it which is everywhere I go.  Samsung!  You need to fix this!

0 Likes
homeflash
Astronaut
Options
Galaxy S Phones
I finally found a fix!! I had the same problem with my s6 active all of a sudden after i woke up. And I came to realize that the DNS on my samsung shows 192.168.10.1 instead of the regular 192.168.1.1. However, my other devices, tablet, iphones, etc had no problem.



So the fix is to change the dynamic ip to static ip. If you need to know what your ips are, you may want to download some software like advance ip scanner, angry ip scanner from your pc to find out first. (or use some app on andriod or iphone to get the ips)



Setting it with static ip with 192.168.1.1 get me going again. At least this is a fix
0 Likes
TT_KING
Constellation
Options
Galaxy S Phones

Change the DNS server in your router

to:8 8 8 8

     8 8 4 4

Thats was working for me!

I talk too Samsung support Sweden.

Good luck.

ronkat
Cosmic Ray
Options
Galaxy S Phones

Can those wise Samsung Sweden support personal explain,
what to do in those public places where you have no access to the router parameters nor can you change dns?

Can you change dns in Stockholm airport's routers?
Issue is NOT SOLVED and workarounds are poor!

0 Likes
TT_KING
Constellation
Options
Galaxy S Phones
For me i only have this problem at home.
0 Likes
userXXkC5OKkj4
Astronaut
Options
Galaxy S Phones
Only change first dns 8.8.8.8 and leave 2nd with internet provider dns ... worked for me
0 Likes