JUMP TO SOLUTION Solved

Original topic:

S20 Ultra not receiving calls

(Topic created: 04-07-2020 08:06 PM)
141521 Views
userJmvrAskEUn
Asteroid
Options
Galaxy S Phones

Hi

I am really annoyed with this phone for the price.

Great for internet etc, but wont receive calls constantly have to restart it, then its fine for 10 mins and drops again. I am with Spark NZ definitely no account problem and others in my house have no issues. SIM works fine in my S9.

Who wants to turn their phone on and off every 15 mins? Callers either get a message saying call person you called cant be reached, or it goes to voicemail. Samsung you need to do a bug fix for this !!. Seems to be a common problem across many carriers

JUMP TO SOLUTION
79 Replies
Marty_NZ
Asteroid
Options
Galaxy S Phones

Same issue here... Im using dual sim. Vodafone for calls and txt, Spark for data.

 

Constantly having issues with calls not being received and going stright to voicemail, also txts not arriving.

 

Toggling flight mode on then off again, seems to resolve the issue.

 

As others have reported this seems to occur after leaving wifi coverage then reentering wifi coverage, then the phone will not receive calls or txt.

 

Clearly from the feedback, this is not an isolated issue, or specific to any one carrier or sim card.

 

A phone that cannot receive phone calls. Samsung, this is simple unacceptable. 

 

 

Marty_NZ
Asteroid
Options
Galaxy S Phones

Out of interest are any of you using dual sim. I am (voda for txt & calls) spark for data.

 

I was initially thinking this might be a dual sim issue, but it appears more widespread

0 Likes
Reply
Anonymous
Not applicable
Options
Galaxy S Phones

Single-SIM user here 🙋‍:male_sign:

Anonymous
Not applicable
Options
Galaxy S Phones

One solution that might work is to force use of the 3G network from the network settings (but I don't think any of us bought a 4G/5G phone to use on 3G). 

 

Also saw this on Vodafone NZ's site, talking about how the issue can be to do with the phone not "polling" the network. http://help.vodafone.co.nz/app/answers/detail/a_id/11758/~/about-delayed-txts-or-missed-calls

0 Likes
Reply
userVJ0bIid1Hi
Constellation
Options
Galaxy S Phones

HI, 

 

I have the same issue with my phone which is really annoying.

 

Has anyone figured out a solution to this problem? I've tried changing my sim and its still the same issue.

0 Likes
Reply
usertUAmB9jg1i
Constellation
Options
Galaxy S Phones

@userJmvrAskEUn  DId you ever get a fix for this? I have the same problem on my s20+ on spark NZ. 

0 Likes
Reply
userJmvrAskEUn
Asteroid
Options
Galaxy S Phones

Hi 

No I didnt, I think most people are still having the same problem. Very poor of Samsung in my opinion. They obviously dont pay attention to these discussions.

userBk5kmSHJGE
Constellation
Options
Galaxy S Phones

I've noticed the same on my S20 plus. Generally it seems to happen when the phone is on WiFi. I just received a call on when on WiFi and it went straight to voice mail, turned off my wifi and the call came through. It's rather frustrating! I've spent so much on this phone, first had issues with the camera not focusing properly now this. 

userNN3h0YNH7z
Asteroid
Options
Galaxy S Phones

I have the exact same issue on my S20 Ultra, getting told by my colleagues that they can't call me through direct line, and had to call me through WhatsApp. I also noticed this when my OTP SMSes for transaction security etc would not come in at all sometimes. I tested calling my phone with another phone while my SMS were not coming in and true enough the call couldn't make it through. Disabling WiFi and enabling mobile data seemed to "wake" the device's network connection and it would then work for some time. 

 

Reporting this issue from Singapore on a device bought in Malaysia (Exynos 990 build).

userVo9C72ewMr
Constellation
Options
Galaxy S Phones

Same problem with my s20+, Sweden/Europe. It's impossible that there is a carrier problem due to its world wide with different carriers. Didn't notice this problem before the last update tho.