JUMP TO SOLUTION Solved

Original topic:

S22 Ultra - Always on display disappears despite set to show always

(Topic created: 05-25-2022 11:41 AM)
7579 Views
springdaleHun
Cosmic Ray
Options
Galaxy S22

Hello, 

I have an issue with my S22 Ultra Exynos. I charge the phone overnight on a wireless charging station. Since always on display is turned on and set to always show, I can check the time in case I wake up.

Sometimes I wake up and find the screen empty without AOD. Unlocking the phone results in a brief flash and after then the always on display works again. The issue does not happen every night and so far hasn't occurred during the day when the phone is unlocked regularly. 

I have everything updated, restarted the phone, force stopped AOD then cleared data. Since the last update (may security patch) the issue seems to be less regular.

It seems like as the AOD app is either crashing or getting killed in order to save battery - the latter is my suspicion. See attached screenshot.

Anyone else experiencing this? 

Thanks! 

Screenshot_20220509-125008_Settings.jpg

1 Solution


Accepted Solutions
Solution
springdaleHun
Cosmic Ray
Options
Galaxy S22

The issue no longer reproduces since installing the June update which was quite big in size.

Samsung, it would be great if your tech support wouldn't automatically suggest a factory reset every single time an issue is reported, especially when a fix is already in the works.

View solution in context

10 Replies
usermzeJaY3BsM
Black Hole
Options
Galaxy S22

See how the AOD is being displayed, go to:

Settings | Lock Screen | Always On Display

Tap the words, not the toggle.  Set this to Show always.  The default for is Tap to show, which is weird for me as this should be Always On by default, as the name "Always On Display" suggests...

0 Likes
Reply
springdaleHun
Cosmic Ray
Options
Galaxy S22

Thanking your reply, as I have stated it is set to always show and usually does so. 

0 Likes
Reply
Options
Galaxy S22
That is peculiar behavior. The screen shot you posted makes it clear you have some savvy with this device, not sure a lot of ppl know how to find that setting for AOD. So the initial response I was prepared to offer - check DND/Sleep settings - I dismiss, as you're sure to have verified that's not the cause. You said this happens overnight WHILE charging... I'd wonder if there's an issue with the charging station. Maybe you can try a wired recharge a couple nights to see if it occurs? If willing, be sure to turn off the Super-Fast charging since it'll be plugged in for several hrs (just my opinion but I think it's best).

Bug report submission if the issue happens on wired charger, too - or with a different wireless charger (which could be an alternate test option instead of wired charger, if you have a different model available than what you usually use).
PaperStation
Supernova
Options
Galaxy S22

This is probably due to it being so dark the phone might be thinking it is in your pocket and the aod turns off in the middle of the night.  That is just my guess on it though.

0 Likes
Reply
ButtaBean_420
Black Hole
Options
Galaxy S22
This same thing happens to me once in awhile it switches itself to power saving mode all you have to do is pull down quick settings menu and toggle power saving mode to off
0 Likes
Reply
springdaleHun
Cosmic Ray
Options
Galaxy S22

Thank you all for the replies. 

- I use an original Samsung wireless charger (fast wireless charging is disabled). Will check with if the issue happens with wired charging and when not charging at all.

- I doubt it has anything to do with sleep/DND settings since the issue does not reproduce itself every night.

- I understand that power saving mode disables the AOD, but why would the phone enter power saving mode during charging?

- Regarding the lighting conditions, for me AOD keeps on even when the phone is in my pocket. The room is not completely dim anyways.

I have received reply to my error report via Samsung Members, stating that since AOD is not a separate app (sic), I should to a factory reset. 

I'll keep you posted. Looks like I'm the only one having this issue?

0 Likes
Reply
springdaleHun
Cosmic Ray
Options
Galaxy S22

Some update in case anyone if interested, the issue now consistently happens every night when the phone is on the charger, whether wireless or not.

In case the phone is not charging the always on display stays on until the morning. 

Next I'll disable the protect battery feature and try another AC adapter and cable. 

0 Likes
Reply
usermzeJaY3BsM
Black Hole
Options
Galaxy S22

Do you have the Screen Saver set in :
Settings | Display | Screen Saver

If so, perhaps this is getting in the way, and disables AOD.

0 Likes
Reply
springdaleHun
Cosmic Ray
Options
Galaxy S22

Thank you for your reply. The screen saver is not enabled. 

0 Likes
Reply