JUMP TO SOLUTION Solved

Original topic:

Do Not Disturb Does Not Respect My Schedule

(Topic created: 02-01-2024 04:54 AM)
393 Views
Sammix
Halo
Options
Galaxy S23

As the images show, I set a "Do not disturb" schedule for every day from 12:00 AM to 7:00 PM.

Screenshot_20240201_073421_Settings.jpg

As you can see, in spite of this, "Do not disturb" is on until I turn it off. How do I get "Do not disturb" to respect my schedule?

Screenshot_20240201_074602_Nova7.jpg

BTW: I composed this message at 7:55 AM. "Do not disturb" is still turned on, regardless of my schedule.

0 Likes

1 Solution


Accepted Solutions
Solution
tc8510
Explorer
Options
Galaxy S23
Turn off DND and it will follow the schedule you set.

Now it will respect your boundaries.

Good luck!1706800905745.jpg

View solution in context

0 Likes
8 Replies
LauraRG
Comet
Options
Galaxy S23
That looks like you have do not disturb just turned on. In the sleeping routine you can make it turn it on at the start of your sleep and then off at the end of it. And it will. I have mine set that way and it worked fine. But when it says turned on until I turn it off that usually means that the user turned it on and set it for until I turn it off. Sleep mode only does that if you set it up in routines.
0 Likes
Sammix
Halo
Options
Galaxy S23

As you can see, I can setup a Schedule in the Settings app.

0 Likes
LauraRG
Comet
Options
Galaxy S23
Right, but with the top one ticked that keeps it on all the time. Not just on that schedule. Here's what it looks like if it is on just by the schedule. See at the top it says on until 7am. Cause sleeping is turned on. The way it looks on your phone it says on until I turn it off. Which means that it was activated outside on the schedule. If I have sleeping turned on and then click the top two times it says the same for mine. 1706794992198.jpg
0 Likes
Sammix
Halo
Options
Galaxy S23

There are no routines or modes setup on my phone. When I setup my Schedule, "I" called it Sleeping.

0 Likes
Solution
tc8510
Explorer
Options
Galaxy S23
Turn off DND and it will follow the schedule you set.

Now it will respect your boundaries.

Good luck!1706800905745.jpg
0 Likes
Sammix
Halo
Options
Galaxy S23

I'll find out tonight and report back tomorrow.

0 Likes
LongHiker
Legendary Samsung Care Ambassador
Options
Galaxy S23

@Sammix Just as a test, I would change your DND start time to 11:59 PM. If that works, then there is some bug where DND thinks that 12 am is after 7 am and therefore never turns off DND. 

Sammix
Halo
Options
Galaxy S23

.. And the very intuitive solution to my problem is:

If you want Do Not Disturb to run on a schedule, don't turn on Do Not Disturb!  Instead, just enter your schedule, save it, and walk away.

Why couldn't I figure that out? (I'm glad someone else did!  😊 )