JUMP TO SOLUTION Solved

Original topic:

Galaxy Active 2 Battery Drain

(Topic created: 08-23-2020 05:46 PM)
6785 Views
useryvDx0mOiaY
Constellation
Options
Galaxy Watch

I recently purchased an Active 2 LTE version from T-Mobile and I noticed the battery cannot last me a full day at all. Regardless of what I do the battery still tends to drain fast. Has anyone had the same issues and been able to resolve this?

userM6I2h1YQfD
Constellation
Options
Galaxy Watch

I am having the same issue.  Just recently bought the watch a couple of weeks ago and I also have TMOBILE and the watch dies within the day. I read up before I bought and it said battery life up to 4 days. Help please. 

0 Likes
Reply
userlyTGPNNhqw
Constellation
Options
Galaxy Watch

I solved it by setting the WIFI to AUTO and NFC to OFF, now the battery lasts for 2-3 days without any problem

0 Likes
Reply
Hawk1
Constellation
Options
Galaxy Watch
my gear active 2 watch battery started draining fast after the last update
Ivan041
Asteroid
Options
Galaxy Watch

Has anyone found a solution to this? My wife and my Active 2 won't last 8 hours now. Battery is draining at an unacceptable rate. We used to get almost 2 days of battery life, now not even 8 hours. 

0 Likes
Reply
userlyTGPNNhqw
Constellation
Options
Galaxy Watch

Did you try leaving only bluettooth to on and all wifi NFC etc. to off?

0 Likes
Reply
userdoXbh0PtGx
Constellation
Options
Galaxy Watch

I have only the bluetooth version and it started only giving me half a day per charge all of a sudden, seemingly after a recent update if I remember right.  So I checked through all of my setting in the Wearables app and found that my wifi had been enabled for some reason.  When I turned that off it is now back to normal 2-day battery life.  Don't know if this would help you or anybody else but I didn't see that it was on when I checked through the settings on the watch but I could tell when I checked the phone app.  It's paired with my galaxy s9+ with latest T-mobile and android updates.

0 Likes
Reply
userTpfiLabULn
Asteroid
Options
Galaxy Watch

I think is the latest firmware update. I am in the same boat. I use to get 2 days on a charge. Now, if I charge to 100% it get drain in a few hours unless I do a shutdown and restart. If I charge to 80% or so, I usually don't run into any issue. Also, if my watch is away from my phone, it drains in couple hours too.

userTpfiLabULn
Asteroid
Options
Galaxy Watch

It seems like for me, Active 2 LTE (not enable LTE yet) with software version R825USQU1ASI1, the drain occures after a full charge and when the watch is away from my phone.

 

This does NOT make any since to me. WHY would charging the watch to 100% drain it in about 6 hours vs charging it to 80% and it last 1.5 days!!!! <edit>.

 

Looks like I moved away from Apple to the Samsung eco system was a major bad move!

user5wjmRsjl79
Constellation
Options
Galaxy Watch

Active 2 LTE tremendous battery drain at work, would hardly last half the work day. At home generally much better, but still somewhat irregular from day to day. Finally figured out was due to very poor cell signal at work, often no service to one bar. WiFi was weak as well. Apparently draining by constantly trying to connect to weak or nonexistent signal. Turned off cell reception and WiFi on watch at work (I have my cell phone anyway), and still have 77% at 2:45pm! Problem solved!!

0 Likes
Reply
userTpfiLabULn
Asteroid
Options
Galaxy Watch

I just download the new version of the firmware and the drain seems to be resolved. I have also notice that the heat when charging seems to have been reduced as well.

 

Unfortunately for Samsung, it came too late. I just got my son his first phone. We decided to go with the iPhone. Samsung lost here for two reason, 1) The GPS issue on my S8 and 2) the battery drain on this watch. Several months to fix both high/very high priorities bugs is un acceptable. I am an IT manager wored on both as a QA manager and now on customer service/deliver, none of my customer would accept this two bugs for more than a couple weeks!

0 Likes
Reply