JUMP TO SOLUTION Solved

Original topic:

Google Maps not showing map on Watch 4 classic

(Topic created: 10-24-2021 05:40 PM)
5325 Views
userJKJsjK2BoA
Constellation
Options
Galaxy Watch
When I open Google Maps on my watch it does not display map. It simply shows a blank screen with grid marks. It will provide written directions but no graphical map. Suggestions? Thanks
0 Likes
Reply
6 Replies
LongHiker
Legendary Samsung Care Ambassador
Options
Galaxy Watch

@userJKJsjK2BoA 

"It simply shows a blank screen with grid marks."

Mine does that when I first open Maps but then shows the map after getting the map info. I'm assuming it gets the map info from the phone. 

"It will provide written directions but no graphical map. Suggestions?"

Try this when you are seeing the directions on your watch, scroll the screen up and you should see a "Show route". Click that and it will show your route on a map. 

What phone is your watch paired to? 

0 Likes
Reply
userJKJsjK2BoA
Constellation
Options
Galaxy Watch
Thanks for responding. When I try that it says loading route but never loads it. I gave it directions to somewhere a half-mile from here thinking it was just going to take a while but it never loaded. It shows up on my phone but never gets transferred to the watch
0 Likes
Reply
Solution
Home_in_BKK
Comet
Options
Galaxy Watch

Is your location ON on the watch?

userJKJsjK2BoA
Constellation
Options
Galaxy Watch
It was, but not for Maps! Thanks for fixing!
0 Likes
Reply
Cosmic730
Asteroid
Options
Galaxy Watch

Could you please clarify this for me? When you say location wasn't set up for maps, where is this? I'm having the same problems with the black screen with grid lines and not loading the route. Would appreciate the help. Thanks

0 Likes
Reply
Home_in_BKK
Comet
Options
Galaxy Watch

On the watch settings:  settings > Privacy > Permission manager > Location.  look for Map and check "allow all the time" or "allow only while in use".

0 Likes
Reply