JUMP TO SOLUTION Solved

Original topic:

Can't update Samsung Odyssey G9 Firmware

(Topic created: 04-05-2021 02:42 AM)
Heartsbane
Astronaut
Options
Monitors and Memory

I've tried following the instructions provided to update the monitor hardware, and can't figure out what I'm doing wrong. 

 

Monitor Model: LC49G95TSSNXZA

Current Software Version: M-T9549GGAA-1005.4

 

I downloaded the latest firmware and unzipped it. There's one file, named: M-T9549GGAA-1008.1[205C].img

 

I tried two different USB Flash Drives, one 2GB and one 32GB. I did a fresh format on both to ensure they were formatted to FAT32.

 

I copied the file to the USB flash drive and plugged it into the SERVICE USB port on the monitor.

 

I went to Support >> Software Update - I get the following message: No update files found on your USB device. (File Name: M-T9549GGAA-****.*)

 

I tried plugging into the other USB port on the monitor and it gives this message: No USB devices detected. Please check and try again. 

 

So I'm pretty sure I had it plugged into the SERVICE USB port to start with, it's just not recognizing the update file.

 

I tried renaming the file and trying again. I tried all of the following filenames:

  - M-T9549GGAA-1008.1[205C].bin (per PDF instructions)

  - M-T9549GGAA-1008.img

  - M-T9549GGAA-1008.bin

 

Same message (no update files found) every time. 

 

What the heck?!? It can't be this hard to update the firmware on this monitor!

0 Likes
Reply
12 Replies
JDitto
Constellation
Options
Monitors and Memory

Very important thing to remember on this.  Fat32 AND MBR must be used on the drive.  8gb or less in size.  Likely those having issues are fat32, but GPT for the boot sector.  You'll have to convert it to the older MBR style to make it work.

0 Likes
Reply
Solution
user0R9QXka2G6
Astronaut
Options
Monitors and Memory

Its all non logical problems with usb sticks. used 1Gb and onother 16Gb. Formated with windows both to FAT32. Didnt worked. Then formated 16gb stick with Rufus, selected non bootable, mbr, fat32.  Then deleted autorun files from stick and added update file. And voila...update started. Hope will help 

View solution in context

SamsungLarry
Community Manager
Community Manager
Options
Monitors and Memory

An Accepted Solution has been marked and provided for this thread. The thread will now be locked for further replies. in hopes to keep the integrity of the thread from steering in a non-technical manner. If you have a separate concern, feel free to post again or send one of our moderators a private message with more details. Please note duplicate posts on similar subjects starting 2/1/21, will be removed to keep our community organized and make it easier for our users to find resolutions and needed content. Remember that if you do make a post, please include as many details about your symptoms as possible. Also, make sure that your title is a good summary of the overall situation that's occurring with your product. Thank you for being part of the community!







Be sure to click " ✓ Accept as Solution" when you find an answer that works for you.





Please note, notification emails are a DO NOT REPLY address, you must log-in on the community page in order to respond.

0 Likes
Reply