JUMP TO SOLUTION Solved

Original topic:

Galaxy Tab S7+ 45w SFC 2.0

(Topic created: 10-06-2023 04:29 PM)
799 Views
asiaminor2k
Cosmic Ray
Options
Tablets

Android 10 + One UI 2.5 got SFC 2.0 speed on a 3rd party power bank. Screen shows SFC 2.0 . No issue.

Upgraded to Android 12 + One UI 4 and the same power bank cannot trigger SFC 2.0 anymore . Seems to be the case on Android 12/higher.

Tested on Note 10+ using Android 10 + One UI 2.5 and SFC 2.0 is triggered as expected .

How to get back SFC 2.0 on One UI 4 and higher ???

1 Solution


Accepted Solutions
Solution
asiaminor2k
Cosmic Ray
Options
Tablets

Got SFC 2 back. Ended up exiting DeX mode and tried plugging again and then it came back, then entered DeX mode again and it's still there. Strange but at least it works.

 

View solution in context

0 Likes
Reply
6 Replies
DanG92263
Honored Contributor
Options
Tablets

Yeah, Samsung has pulled back from SFC every since their batteries started exploding and catching on fire, which got one of their phones banned by the airlines. Good luck with that.

0 Likes
Reply
asiaminor2k
Cosmic Ray
Options
Tablets

That explains why S23 Ultra still has 45w Charging...

The phone that got banned was NOTE 7 (ish). Old device.

0 Likes
Reply
DanG92263
Honored Contributor
Options
Tablets
Yep. 2017, but corporations tend to have a long memory when they get suited and banned like that. It it one of the reason you can buy a high end phone with a replaceable battery.
0 Likes
Reply
user_ams007
Samsung Care Ambassador
Options
Tablets
Super fast charging is still available but it has been removed from the menu option, Screenshot_20231007_013127_Device care.jpgScreenshot_20231007_013206_Device care.jpg
0 Likes
Reply
asiaminor2k
Cosmic Ray
Options
Tablets

Galaxy Tab S7+... One UI 2.5 showed Super Fast Charging 2.0 (45w timing) . One UI 4 (after upgrade) shows Super Fast Charging (25w timing) for the same charger. Something changed in One UI 4.

0 Likes
Reply
Solution
asiaminor2k
Cosmic Ray
Options
Tablets

Got SFC 2 back. Ended up exiting DeX mode and tried plugging again and then it came back, then entered DeX mode again and it's still there. Strange but at least it works.

 

0 Likes
Reply