JUMP TO SOLUTION Solved

Original topic:

Samsung Tab S7+ Spell check isn't working (using physical keyboard)

(Topic created: 11-24-2020 05:46 AM)
15306 Views
Options
Tablets

Hello,

 
I have a Tab S7+ and the spell check isn't working anywhere (e.g. Samsung Internet, Chrome, etc).  When I use Google to look for a way to turn it on, the instructions do not match the Tab S7+.  I'm using the $230 physical keyboard and expect spell checking to be available.  (Is having spell check to much to ask?)
 
NOTE:  I have a Note 20 Ultra and the spell check is working fine.
 
I just got off the phone with Samsung support.  They found the predictive and spell checking don't work with the physical keyboard.  They work with the on-screen keyboard, which IMHO is not good given the size and weight of the tablet.
 
I know getting Samsung to fix software issues is next to impossible.  The only solution I'm seeing (unless someone can give me a fix) is to return both the keyboard and tablet.  Wait for the Tab S8 Plus.  Sigh ...  I like this tablet, but not the on-screen keyboard.  The physical keyboard is finally one on which I can touch type.
 
 
9 Replies
XrayEyes
Constellation
Options
Tablets

I too found this out. As soon as you disconnect the keyboard spell check works just fine. This needs to be fixed.
This is my fist Galaxy Tab and I also sprung for the physical keyboard and it blows that I have to manually check my spelling before sending correspondence.
I have not tried it out while in Dex mode but I will and see if it is any better there, but Iam not holding my breath.

Update: It does not work while in Dex mode either. Please fix Samsung!
Options
Tablets

Thank you for your observations and confirmation of the problem.

 

A proper solution, obviously, doesn't include discarding the physical keyboard for the on-screen keyboard - not after spending US$230 for it.

 

I love being able to type with two hand, as I learned in my HS personal typing class.  Phone keyboards with one finger typing is outrageously horrible!  Yet, we need both predictive and spell checking with the physical keyboard, too!  Best of both worlds!

0 Likes
Reply
Solution
CiscoS9
Astronaut
Options
Tablets

I think I found the fix for this.

 

Open in DeX

Goto Settings

General Management

Language and Input 

On-screen Keyboard

Select Samsung Keyboard

Smart Typing

Auto Spell check

Select english

 

For me English was not selected. As soon as I made the change, outlook started displaying the red underline to spell check the word. I tested it on other apps and the same results. However it will not spell check text written in the browser.

 

Hope this gets fix soon

 

wapiti300rum
Astronaut
Options
Tablets

I was having the same problem. Very frustrating. I just tried your suggestion and now it works great. Thanks!!!!!

0 Likes
Reply
Options
Tablets

Hello,

I'm sorry but I'm not following your instructions.  Can you describe what you mean by Open Dex, as an example.  I searched for Dex in the settings, but nothing matched what follows.

I'm not trying to connect to a computer / Windows or external monitor, etc.  I'm just using the S7/S7+ keyboard.

michae1s
Astronaut
Options
Tablets
Found another work around while we wait for Samsung to fix this issue. If you download a third party keyboard app it can interact with your physical keyboard. Microsoft SwiftKey will show predictive text/spell correct at the bottom of the screen kind of like an iPad
0 Likes
Reply
Jdlapera44
Astronaut
Options
Tablets
Swift Key does not work while in Dex mode unfortunately.
0 Likes
Reply
PaulvsGodzilla
Astronaut
Options
Tablets
Thanks! CiscoS9
0 Likes
Reply
Options
Tablets
Any word from Samsung on fixing this issue?