Original topic:

Switching screens cause apps to close and reset

(Topic created: 04-14-2024 11:37 AM)
1959 Views
alleykatt
Asteroid
Options
Galaxy S Phones

How do I stop my apps from closing and reseting every time I switch screens?

Does anyone know why it keeps doing this? Is there a way I can stop it? 
10 Replies
VerbumVeritum
Legendary Samsung Care Ambassador
Options
Galaxy S Phones
Try this. Install Samsung's Good Guardians app from the Galaxy Store. Inside Good Guardians, find the Memory Guardian module. Select the Customize tab at the bottom, then set this to "Quick switching mode".
alleykatt
Asteroid
Options
Galaxy S Phones
I have to download yet another app just to get my phone to do what it originally did when I bought it. Smh. What exactly does this app do?
0 Likes
VerbumVeritum
Legendary Samsung Care Ambassador
Options
Galaxy S Phones
Memory Guardian offers a way to free up RAM, view your usage history, and change how cached apps are treated. You could also try setting making sure these the apps in question have Unrestricted battery access in Settings>Apps>app name>Battery. There is also "Suspend execution for cached apps" in Developer settings.
alleykatt
Asteroid
Options
Galaxy S Phones
I'm not sure that is what I need. What I'm trying to do is this:
Let's say I'm writing a note and someone calls or text or even if I have to look something up on another app or the internet. Once I switch back to my notes it resets the screen as if I closed and reopened the app. I do not want that. I don't need more ram.
VerbumVeritum
Legendary Samsung Care Ambassador
Options
Galaxy S Phones
Yes, this used to happen frequently for me as well. This has to do with the way cached apps are stored in the background, which uses RAM. Did you try the battery option? The Memory Guardian setting has reliably worked for me.
alleykatt
Asteroid
Options
Galaxy S Phones
OK I will try it. Thanks for the help. If I have any issues I will let you know. Thanks again.
Ch_k37
Sun
Options
Galaxy S Phones
Try to not put YOUR APPS in DEEP SLEEP MODE OR SLEEP MODE...

1. Go to Settings
2. Go To Device Care
3. Tap "BATTERY"
4. Tap "BACKGROUND USAGE LIMIT"
5. and try to put never sleeping apps..
Ch_k37
Sun
Options
Galaxy S Phones
here the steps:1713150783995.jpg1713150784004.jpg1713150784015.jpg1713150784027.jpg
alleykatt
Asteroid
Options
Galaxy S Phones
I appreciate all your help
0 Likes