Original topic:

Is this only a Verizon problem?

(Topic created: 05-12-2024 03:11 PM)
529 Views
hbelkin
Halo
Options
Galaxy S22
I have an s22 on Verizon network. In my home Verizon coverage is very poor because we're right near water. I often have only one bar. However when I'm home I'm always connected to my strong Wi-Fi signal and I have Wi-Fi calling turned on. So everything is fine on outgoing calling. HOWEVER... I frequently missed calls even when I'm holding the phone in my hand because they do not ring but rather go straight to voicemail. My understanding from Verizon is that if I'm connected to Wi-Fi and registered on their Network the incoming call should find me through the Wi-Fi. 

After some experimentation, I discovered that if I have NO carrier signal such as if I turn on airplane mode, incoming calls find me just fine through the Wi-Fi. But if I have a weak signal, enough to identify the phone, it seems to determine that there is not enough signal to complete the call and rather than route to Wi-Fi it routes to voicemail. Silently. Very annoying. 

I haven't found a good way around this other than turning on airplane mode when I'm home -- but then some two-factor identification methods that require SMS don't go through. And I'm always afraid I'll forget to turn off airplane mode when I leave the house and be unreachable...

Anyone see this on any other carrier? I'm wondering if it's just something in the way Verizon is handling Wi-Fi calling, or is this just the way cell phone service works? Other than install cell phone extender in my house (which I don't want to do) does anybody have any suggestions? 


11 Replies
mike42042071281
Cosmic Ray
Options
Galaxy S22
Have you checked the apn settings that's in the connections settings. Search for Verizon apn settings and compare
0 Likes
hbelkin
Halo
Options
Galaxy S22
Yes, all seems ok. Verizon has also tried to figure it out and has been unable to. Since it works in airplane mode i believe my evaluation is correct
0 Likes
mike42042071281
Cosmic Ray
Options
Galaxy S22
I have lots of missed calls and I have strong signal so I hope you have better luck
0 Likes
mike42042071281
Cosmic Ray
Options
Galaxy S22
You can look in network settings and there should be an option to turn off connect to mobile network while on wifi. I won't fix all the issues but it should help with it splitting onto cell service while on wifi. Open wifi settings then 3 dots in corner intelligent wifi then switch to mobile network. I hope it helps but I'm on straight talk and I miss calls all the time. Only way I know is voicemail go figure
0 Likes
hbelkin
Halo
Options
Galaxy S22
That option is to switch to cell connection if wifi is weak.... I need the opposite!
1715557451505.jpg
0 Likes
1hrcoupon
Asteroid
Options
Galaxy S22
No your problem is in presets and Verizon will toggled the settings to 2g in the data plan so go to settings and reset your network connection then make sure you connect to a randomly generated network and make sure wifi is not working on your mobile data connection wifi does that if all desttings are on automatic. Data mining is more your issue not service. Bit coin mining changes data settings
0 Likes
GaryB82
Epic Samsung Care Ambassador
Options
Galaxy S22
I would suggest contacting Verizon and getting one of there cell boosters if you have hardly no signal at your house they provide them most time for free that's what we had to do last year it's a box that plugs into your network and boosts the signal
https://www.verizon.com/products/verizon-lte-network-extender/?sku=sku3880045


If you've found my post to be helpful, Please like my Comments ✓✓✓.
If my response resolved your issue, please press the Like and ✓✓✓ to Accept as Solution button.


0 Likes
hbelkin
Halo
Options
Galaxy S22
Thanks. I actually already have one, but I don't want to use it. It's like putting a mini cell tower in a small apartment... Not interested in that extra emf radiation constantly. And my wife is especially emf sensitive. But yes, that does solve the problem.
0 Likes
Robin621k
Neutron Star
Options
Galaxy S22
Have you updated it to 6.1 yet?
Was your phone purchased from Verizon?
I found this on Verizon's update page of what is being added to the 6.1 update for the S22 series. You should now be able to access the ability to toggle off 5G.

I don't know if it is only for Verizon locked phones.1715623605964.jpg
0 Likes