Original topic:

NVMe SSD crashes and disappears in Windows 10

(Topic created: 12-27-2020 06:30 PM)
Monitors and Memory

I have two Samsung 970 EVO Plus NVMe SSDs in my system that keep disappearing in Windows and I am unable to access them again until I restart my PC. They do appear in BIOS and Windows on start up, but once I try to access them in any manner, they crash and become unavailable.  Even attempting a simple Performance Benchmark in Samsung Magician on either drive fails and causes this to happen.  
INFO:  Windows 10 has always been installed on an 860 EVO SATA SSD (which I’ve never had issues with), since building this entire machine fresh about a year ago.  I have only used the NVMe drives as storage, mostly for game installs.  HWiNFO64 shows device health at 99% for both NVMe drives.  All device firmware is up-to-date (verified using Samsung Magician).  All system drivers and Windows 10 updates are current as well.  
This disappearing issue recently started happening after flashing to the latest BIOS version for my motherboard in early November.  I also did a clean install of Windows 10 afterwards since v. 20H2 was relatively new.   
What's driving me nuts is, this has happened before. I can’t recall exactly what caused it the last time (either a previous BIOS flash or the Windows 10 v. 2004 update in May), but regardless, I was eventually able to fix it and had been using the NVMe drives normally for months without failures.   Unfortunately, I also can’t remember what combination of things I did to fix it last time, as it took a few weeks of trial and error.  It's been well over a month this time around, though, and I'm running out of ideas. 




MOTHERBOARD: Gigabyte z390 Aorus Master (F11l Bios) 

CPU: Intel i7-9700k @ 3.60GHz (with EVGA CLC 240 AIO Cooler)  
GPU: EVGA RTX 2080 Super FTW3 Hybrid  
PSU: Seasonic FOCUS GX-750 (750W 80+ Gold)  
MEMORY: G. Skill Ripjaws V DDR4 32GB RAM (4x8GB @ 3200MHz)  
STORAGE: Samsung 970 EVO Plus 1TB NVMe SSD  
STORAGE: Samsung 970 EVO Plus 2TB NVMe SSD  
OS: Windows 10 Home Edition, 64-bit, Version 20H2  


EVENT VIEWER ERRORS:  (when the NVMe drives disappear)  


WARNING – stornvme – Event ID 129: Reset to device, \Device\RaidPort*, was issued.  
ERROR – stornvme – Event ID 11: The driver detected a controller error on \Device\RaidPort*.  
ERROR – WHEA-Logger – Event ID 1: A fatal hardware error has occurred. A record describing the condition is contained in the data section of this event.  
WARNING – disk – Event ID 51: An error was detected on device \Device\Harddisk*\DR* during a paging operation.  
 *1 and/or 2, depending on which drive crashed 

I'm also seeing a few NTFS Warnings, such as: 'The system failed to flush data to the transaction log. Corruption may occur in VolumeId: D:, DeviceName:  \Device\HarddiskVolume5' (or some other random Volume number).  This seems odd to me because I only create a single Simple volume on each NVMe drive via Disk Management whenever I initialize and format them.   I also wipe the drives (using DISKPART Clean and/or Samsung Secure Erase) before reformatting. 


Anyways, it's obvious there is some kind of NVMe controller issue or conflict, but what is causing it? Am I doing something wrong? Also, why am I seeing RaidPort errors when nothing is set up in a RAID configuration?  Is that normal, even when ACHI is enabled in BIOS?

I've tried repairing Windows;  I've tried reinstalling Windows clean after each version update to minimize errors; I've even tried mounting only one NVMe on the motherboard at a time...but ultimately, nothing seems to be working.  Any help would be greatly appreciated.  Thank you! 

4 Replies
Monitors and Memory

Bios updates are not always good.  Revert your Bios to the  previous version and try again.



Monitors and Memory

SOLVED!    Turns out that a fan hub I had installed somehow chipped and broke off, at the point where it connects to the power cable that plugs into the PSU, and was causing all this strange behavior. Everything is running smoothly now that it's been removed and the NVMe drives are working properly again.   Honestly, my PC seems to be running better than it ever has, so that fan hub connection must of been degrading or broke off some time ago and I just never realized it (it was an incredibly small, inconspicuous break too so I just barely noticed it while I was redoing cables).


I never would have thought that a fan hub, of all things, would end up being the cause of my NVMe drives disappearing. Since the broken connection on the hub was causing a short, it wasn't letting Windows install correctly, and therefore the motherboard wasn't installing chipsets and updates correctly either. 


If anyone else runs into this problem in the future and stumbles on this thread looking for answers, definitely try the following steps


"Use the BIOS defaults for the most part as subtle seemingly minor changes may be causing issues.


I suggest that you remove your NVMe drives and then install the latest W10 version to your SATA boot drive.  Do some more testing with the latest drivers and without the Samsung NVMe m.2 SSDs installed.  You can still test and use the Samsung Magician on your 860. 


Don't install any RGB H/W or S/W and don't install any Gigabyte software.  Keep your system clean for now while you do more testing.

You might try unplugging and re-plugging all of the cables going to the system board.  Look for possible chassis electrical shorts.

I have seen systems act weird with intermittent errors in the past due to a flakey power supply. The PSU might be a possibility for strange system behavior."

Credit goes to user bigdave on the Gigabyte forums for providing the above info.  Everything they offered is sound advice in narrowing down the problem right from the get-go, regardless of your motherboard or SSD manufacturer.  Likewise, @ddaniel51's advice posted here is also great and could absolutely be a cause of a NVMe SSD disappearing too.  Thanks everyone!

Monitors and Memory

I've been experiencing a nearly identical set of symptoms with my Samsung 970 EVO 1 TB SSD. The drive is visible in the BIOS, but not detected by windows on the first boot, I need to boot, then restart and then it's detected. EventViewer shows the same stornvme errors. It just started failing on me a couple days ago. This is the 3rd time it has happened. I have a Samsung 970 PRO 512 GB on the same motherboard (both connected via M.2) which has never given me any issues.

The two times this happened before were spaced apart by several months. Both times it started failing intermittently and eventually reached a point where it was unusable, but I managed to get it to work again through a combination of research, trial/error and reinstalling windows. Each time this has happened I spend a few weeks researching and manage to get it up and running. Then it happens again.  And I do the same trial/error process to get it working again. Just a couple days ago it happened for the 3rd time and I'm trying to find a more permanent "fix".

So begins my 3rd round of diagnosing and reinstalling windows. Going to try and see if I can find any power supply related problems as you indicated this was the primary cause of your issue.

Monitors and Memory

Refer to this article and you can learn install windows 10 on ssd