JUMP TO SOLUTION Solved

Original topic:

S9 FE Won't Share With Messenger

(Topic created: 04-11-2024 06:51 AM)
476 Views
usere1S8xW8Xhk
Asteroid
Options
Tablets

Hi,

Just setting up a new S9 FE Wi-Fi 256GB, probably at least the 7th or 8th Samsung phone or tabletScreenshot_20240411_002301_Settings.jpg I've set up over the years and am running into a problem I've never had before. 

I was trying to share a photo from Gallery to Messenger (to myself to use on Facebook), something I've done hundreds of times in the past on previous Samsung tablets and phones.

However, this time I keep getting a pop up saying 

"Allow Messenger to access your camera roll?

Allow Messenger access to your storage to send content from external apps.

To enable this, click App Settings below and activate Camera Roll under the  Permissions menu."

I followed the link and started by activating Camera (no option specifically for Camera Roll?) which didn't help so in the end have activated all permissions, restarted and turned off and on a number of times but keep getting the same message!

What am I doing wrong please? 

TIA,

Gary

0 Likes

1 Solution


Accepted Solutions
Solution
usere1S8xW8Xhk
Asteroid
Options
Tablets

I'm glad others had or were able to reproduce the same problem as initially I thought I'd missed something obvious. 

FYI - as a matter of interest I just uninstalled Messenger and reinstalled it. Exactly the same version as before (453.0.0.38.109) but now it shares as expected! 😯  Weird!

Tried another share to double check - all good! 👍🏻

Don't know if this counts as the solution or not???

View solution in context

0 Likes
5 Replies
LongHiker
Legendary Samsung Care Ambassador
Options
Tablets

@usere1S8xW8Xhk Are you setting up Messenger without clicking through from Facebook? 

I saw your post and, as a test, I setup Facebook on my Tab S9+ and then clicked to open Messenger. I was never asked to provide permission for photos. Messenger has no problem accessing the photos on my Tab S9+.

usere1S8xW8Xhk
Asteroid
Options
Tablets

Sorry LongHiker, I'm not quite sure exactly what you mean.  As on all my previous Samsung phones and tablets I've always had Facebook and Messenger set up as apps and never had this issue before.  

Whenever I need to post an old photo to Facebook, one that doesn't appear in Facebook's currently accessible list I go into Gallery to find it and then share to myself on Messenger.  Then I can go into Messenger and save it which makes it the very first photo Facebook gives me the option of selecting. 

Has worked perfectly in all the years I've been on Facebook and only ever had Samsung phones and tablets.

bill-e
Epic Samsung Care Ambassador
Options
Tablets
I just tried your workflow and got the same results. to my knowledge there has never been a "camera roll" permission in at least the last 4 years.
I believe that Messenger is causing them issue, so I would send an error report to them as well as via the Members app to Samsung
** If my response helps, please click on Like (Heart). If I resolved your issue also please click on Accept as a Solution so that others can benefit.

Bill
---
Galaxy Fold 5 512g(VZW), Galaxy Book (original, VZW), Tab S8 Ultra, Tab S4, Galaxy Watch6Classic 47mm(VZW), Galaxy Watch5Pro(VZW), M8 Smart Monitor, NEO 55" QN90D TV
0 Likes
jujubee51170
Astronaut
Options
Tablets
I'm having the same problem trying to send pictures from my gallery to anyone in my messenger. I've tried every answer that was given on this blog
0 Likes
Solution
usere1S8xW8Xhk
Asteroid
Options
Tablets

I'm glad others had or were able to reproduce the same problem as initially I thought I'd missed something obvious. 

FYI - as a matter of interest I just uninstalled Messenger and reinstalled it. Exactly the same version as before (453.0.0.38.109) but now it shares as expected! 😯  Weird!

Tried another share to double check - all good! 👍🏻

Don't know if this counts as the solution or not???

0 Likes