JUMP TO SOLUTION Solved

Original topic:

google calendar not syncing!

(Topic created: 11-03-2019 07:29 AM)
McVitas
Halo
Options
Galaxy S Phones

Hello, this makes my life harder a lot! I use calendar on the phone and also on the computer. But I noticed entries made on the phone are not visible online in google calendar online! When I checked phone settings / accounts it is set to be synchronized, but from some reason Calendar last sync date is very old! I did a manual sync and it worked. Like two weeks later I noticed again calendars not being synced. My settings shows the last calendar sync was the manual sync I made and no sync since then happened! I want my calendar to sync so events written on phone appear in google online. And yes, my gmail account is set as default calendar when creating events on the phone.

Screenshot_20191028-165909_Settings.jpg

15 Replies
SamsungLarryK
Samsung Moderator
Samsung Moderator
Options
Galaxy S Phones

Have you tried removing your Gmail account and re-adding it?

0 Likes
Reply
McVitas
Halo
Options
Galaxy S Phones

no, that did not occur to me. Will try... But it seems like a big "cut" in the system where so many things are tied to my google account ...

0 Likes
Reply
Solution
McVitas
Halo
Options
Galaxy S Phones

So I found the solution and I really wonder why no moderator asked me to check this! Removing and readding account does not make sense if everything else works of course...

CAUSE: I have set my phone into medium power saving mode to try to prolong battery life. It seems that this have caused several problems because it disabled some essential system apps!

I found two problems so far:

Google Photos suddenly stopped uploading my photos into cloud and it worked only when the app was open and always stopped once display timeout happened and phone locked itself!

Calendar stopped syncing

SOLUTION:

nothing easy and intuitive, but finally I found out that I should go to settings / applications / special access / battery optimized apps and switch the list to all. After long browsing I found Calendar Synchronization and also Google Photos. I toggled the checboxes off and voila - photos are now syncing and calendar as well!

And no you can't find them in the obvious place - device care / battery / sleeping apps, so that makes it extra difficult to figure out.

View solution in context

McVitas
Halo
Options
Galaxy S Phones

not sure why the picture in my OP was not visible - uploaded it again so hopefully it will stay.

SAMSUNG I have a suggestion for fix in the next update! It seems that none of that settings in accounts / my google account / synchronization makes any sense IF user chooses power savings profile. As you can see those last sync dates are all random which probably means the automatic sync DOES NOT happen unless user opens the respective app! So it would be much better if these settings actually reflect reality - meaning that if user switches to medium or max power savings battery mode these settings would all switch to off state and there can be a popup explaining that this happened. If you go in this settings there would be a message "automatic synchronization is off due to your chosen power saving profile". That would make much more sense and would be true. Looking forward to this fix. Thanks

userXqCEV3D6w0
Constellation
Options
Galaxy S Phones

THANK YOU. I was so frustrated with this on my new s10e. For years I have had Samsung phones that synced perfectly to Google calendar. This new phone has been hit-or-miss.

(My path to the battery optimization feature is different on the s10e but I found my way.) 

(Yesterday this same phone stop letting me dial out for several hours! Battery had more than 60%charge! So when I unchecked the battery optimization feature for my calendar, I did the same with CALL. I hope it never happens again. DANGEROUS.) 

LOVEloise
Astronaut
Options
Galaxy S Phones

Thank you so much!! This fixed it instantly! I spent ages trawling the internet for the answer. Really appreciate you sharing and explaining. 

0 Likes
Reply
user9p1t3TKcQA
Astronaut
Options
Galaxy S Phones

classic Samsung (and others - Xiaomi, Huawei etc).

 

Every manufacturer just break standards and dont follow rules, add their own battery optimization "features" on top of default android, etc etc - and half of the time things dont work or work different than on other phones.

0 Likes
Reply
userYzWj72zmOr
Astronaut
Options
Galaxy S Phones

THANK YOU!!!! This has been driving me crazy for MONTHS! Tried it, and it fixed it straight away. Great is the sound of thy rocking.

0 Likes
Reply
Samsung Ryder
Samsung Moderator
Samsung Moderator
Options
Galaxy S Phones

An Accepted Solution has been marked, and provided for this thread. The thread will now be locked for further replies. in hopes to keep the integrity of the thread from steering in a non-technical manner. We understand the solution marked may not be a solution for everyone, If you have a separate concern or question, feel free to Private message a moderator or post a new thread with additional details. Please note duplicate posts on similar subjects starting 2/1/21, will be removed in order to keep our community organized and make it easier for our users to find needed content. Remember that if you do make a new post, please include as many details about your symptoms as possible. Also, make sure that your title is a good summary of the overall situation that's occurring. Thank you for being part of the community!

0 Likes
Reply