Original topic:

S21 unable to make or receive calls after Android 13 Update

(Topic created: 12-07-2022 02:39 AM)
Galaxy S21

I've a frequent issue where my Samsung S21 is unable to receive calls of SMS messages. I suspect it started after the recent update to Android 13 in November, but given it's only when people ring me it's not something I noticed right away until people mentioned it to me.

Samsung S21 on O2 (SIM1) and Giff Gaff (SIM2). SIM2 is never used for calls/data/texts and has data disabled.

The flow is that someone calls me (to SIM1, O2) and to them it rings, but my handset does nothing. After a couple of rings it goes to voicemail. The last part of this has changed in the last week or so, where the call doesn't even hit voicemail and instead gets either "“the number you have called is not recognised. Please check the number. If you need help call the operator on 100 from your mobile” and it doesn’t even now hit voicemail or more recently "it has not been possible to connect your call".

Initially I'd get a missed call SMS from O2 after a few hours of the actual call, usually when leaving the house or after rebooting the phone. This now doesn't make any difference.

Things I've tried:
*Check home network firewall. There are no ports blocked nor SSL inspection or other policies applied that could block WiFi calling
*When calls DON'T work, data is working fine and I can get around 70Mbps download on 4G+ with 3 out of 4 bars of signal. Data also works fine when calling is working. 
*Restarting the phone occasionally fixes this for a short while before reverting to the faulty behaviour
*WiFi calling is disabled, no improvement
*4G calling disabled, no improvement
*Disabled all call forwards, no improvement (I suspect this may be what broke the voicemail though)
*Disabled 5G, no improvement
*Disabled 5G and 4G, no improvement
*Cleaned SIM contacts with isopropyl alcohol, no improvement
*SIM1 (O2) in different phone (Samsung S5) - calls always come through fine to the Samsung S5
*Kept SIM2 (GiffGaff) in the same slot - calls always come through fine to GiffGaff regardless 
*Moved SIM2 (GiffGaff) to SIM1 slot - out of numerous tests calling the GiffGaff number only one call didn't go through but did hit voicemail. The fail rate for the O2 SIM was far far higher where I could more often than not recreate the issue, so I'm confident the GiffGaff SIM is unaffected as is SIM1 slot. 

Here's a flow of when I can recreate the fault:
*Worked fine at home. Left the house, came back home, getting “it has not been possible to connect your call, please try again later”.
*Turned off the phone and with it turned off tried calling it. Still getting “it has not been possible to connect your call, please try again later”.
*Turned phone back on, didn’t enter PIN or interact after powering on and got the same issue.
*Entered PIN, screen was unlocked, same issue.
*Screen still on from the unlock, turned off WiFi, call connected just fine.
*Screen still on from the last successful call, WiFi back on, call worked fine again.
*Screen timed out and locked. Called it and went through just fine.
*Turned phone off and called it, expecting to get a voicemail but doesn’t hit voicemail
*Powered phone on, without entering PIN or touching it I called it again (still on WiFi from the earlier test) – call went through just fine.

I'm hoping to get a replacement O2 SIM, however given it works fine in the Samsung S5 handset I'm not convinced it'll make a difference. I'm fairly confident that the issue is with the Samsung S21 and the November update so if the SIM makes no difference I'll need to get a new handset (sorry, but it probably won't be another Samsung if this is an example of their QC for updates).

5 Replies
Galaxy S21

Additional things I've tried since posting the above:

*Swapped SIMs, O2 to SIM2 and GiffGaff to SIM1. Immediately could recreate the issue calling the O2 SIM. The GiffGaff SIM continues to work fine. Rules out contacts on the SIM slot
*Disabled data for the O2 SIM - no improvement
*Reset network settings. This changed the default for data to the GiffGaff SIM which I left as-is. The call went through for the 1st test. I then changed data to use the O2 SIM. Subsequent tests then failed in exactly the usual way ("it has not been possible to connect your call"). Putting data back to GiffGaff allowed one call to come through to O2 fine but every call after this failed. Every time the setting was toggled it allowed one call through with every following call failing until the setting was toggled again.
*Toggling Mobile data to "off" rather than setting a SIM for the data does not allow any calls through. It is only when changing between the SIMs for data that the call comes through for one call only.
*Changing other "Preferred SIM" settings has no effect, it is only when data is toggled between SIMs that one call is permitted.
*Also worth noting that resetting the network settings did not recover voicemail, i.e. calls continue to never hit voicemail.

Galaxy S21

Adding a bit more as I realised I failed to disclose that I'd tested outbound calling:

*When calls are failing inbound, the O2 SIM can call outbound SOMETIMES and it rings the other phone for one ring only then cuts off with a message on screen "number invalid". Most of the time however outbound calls sit at "Calling" with no dial tone etc for as long as it likes - I lost patience at 3 minutes. It will also sometimes immediately transition to "Call ended" without even attempting to connect.

Galaxy S21
The same thing has happened on my Z flip 4 after the update. I thought it was carrier related but a non samsung phone on the same carrier was able to make wifi calls just fine.
Galaxy S21

Thanks for the feedback.

I got a brand new out the box Samsung S21... Same problem exists.

Thankfully it's a company phone so it's not cost me anything. Our internal IT updated it to Android 13 and shipped it to me. I put my SIM in and it worked just fine. This was just the O2 SIM however. Out of around 5 to 10 test calls all were connecting ok.

I then enrolled into Intune and put my 2nd SIM in, and transferred data from the original S21.

When it came to setting up apps I noticed the MFA SMS codes were taking a while or not coming through. When I tried to call the O2 SIM number it's doing exactly the same issue of not connecting. Likewise, outbound calls still don't work. 

Thinking it might be an app with call permissions intercepting the call and messing things up I checked out permissions but everything there is either a default Google or Samsung app. 


  • The act of putting the 2nd SIM in killed it (perhaps... although the issue only ever seems to affect the O2 SIM and not the GiffGaff SIM)
  • The enrollment to Intune killed it (unlikely as we've got probably 50 Samsung S21's enrolled in Intune with the same policies)
  • Some update after setting up the new phone killed it (possible although I didn't see any updates happen after the 1st round of successful tests)
  • Some app on the phone killed it (unlikely as there's no user installed apps with call permissions)
  • Some setting in the phone copied over from the original S21 and broke it (unlikely as I'd already done network setting resets)

Unfortunately I'm burning far too much time trying to fix this so as a potential quick win will get a new SIM and see if that miraculously resurrects things. If it doesn't at least I've got an identical phone to test with and take back to factory settings, then incrementally test things like enrolling to Intune, installing one app at a time etc. 

Community Manager
Community Manager
Galaxy S21

I apologize, but you have reached technical support for products manufactured for usage in the United States. Please visit https://www.samsung.com/us/common/visitlocationsite.html  to find your country's support page.