Original topic:

S24+ Home Wi-Fi issue

(Topic created: 4 weeks ago)
662 Views
Abel727
Constellation
Options
Galaxy S24
When I connect my S24+ (US Unlocked Version) with my Home XFINITY Wi-Fi network apps like reddit,Instagram,youtube sometimes won't reload.
But when i connect it to a Open Wi-Fi Network or Mobile Data it works again.
I don't have this problem with iPhones or other Android phones from other brands.
How can I fix this issue? 
11 Replies
realaud
Honored Contributor
Options
Galaxy S24

Sounds like someone put restrictions on your home network, like disallowed access to certain domains. If you are the administrator of your home network, go into the modem settings and see if anything is restricted, if yes, then remove the restrictions.  If you are not the administrator of your home network, ask the person who is if they put restrictions on and can they take them off. 

0 Likes
ta-ku-sa
Constellation
Options
Galaxy S24
I tried everything I found online. The only thing that works for me (with the help of netgear support) is to disable smart connect on my wifi 7 router and connect to 6 GHz on my s24 ultra.
#samsung (please fix this problem)
0 Likes
realaud
Honored Contributor
Options
Galaxy S24

Why are you asking Samsung to fix something that is your router's problem?  Obviously, your router's smart connect feature is the issue.  Smart connect tries to connect devices to what it thinks is the best network for it, even if it's incorrect.  Which is why I have to keep my 2.4 & 5 ghz networks unbridged on my router.  The smart home devices that only connect to 2.4 Ghz get confused when the networks are bridged, because the router tries to route everything to the higher frequency, even if the devices can't handle it.

0 Likes
ta-ku-sa
Constellation
Options
Galaxy S24
It must not be the router due to the fact that my iphone 15 work issued phone has no problem connecting to 6Ghz on wifi 7.
0 Likes
realaud
Honored Contributor
Options
Galaxy S24

Their iPhone is an iPhone and yours is a Galaxy. The hardware us different and is obviously capable of handling and being automatically routed to WiFi 7. Your phone is not. You will have to direct it to wifi 6 or turn off the auto switch in your router as you have done. It's not Samsung's problem to fix, it's yours. Wifi7 is not even supported on S24s with the Exynos processor. Which processor does your phone have?  I'm also willing to bet there is no significant difference between wifi7 and wifi6, and if your phone works well with wifi6, that's where you should keep it.

0 Likes
ta-ku-sa
Constellation
Options
Galaxy S24
My phone has Qualcomm Snapdragon. Consider googling wifi7 vs wifi6 for info.
0 Likes
realaud
Honored Contributor
Options
Galaxy S24

You did not specify which processor you have.  Some S24s have one, others have the other.  Still sounds like a you problem.

0 Likes
ta-ku-sa
Constellation
Options
Galaxy S24
My bad, ARM ARMv8 @ 2.26GHz 1Processor, 8 Cores (this is what is read when I google model name SM-S928U1)
0 Likes
realaud
Honored Contributor
Options
Galaxy S24

Well, it does seem as if you have a processor that supports Wi-Fi 7, but keep in mind this is first generation of phones with this capability from Samsung, so it may not work as well as expected.  Do you connect to Wi-Fi 7 out of your home?  If you do, it really could be that the router is wrong for your phone.  

You should put in an error report with Samsung. Settings/general management/contact us - or use the support link at the bottom of the front page of the members app.

0 Likes