JUMP TO SOLUTION Solved

Original topic:

49" Odyssey G9 Neo - No signal from the DisplayPort

(Topic created: 04-24-2022 07:26 AM)
23273 Views
userxZPq6avjHv
Asteroid
Options
Monitors and Memory

Just got a 49" Odyssey G9 Neo, but can't get a signal from the DisplayPort connection.

HDMI works just fine.

I have tried the following troubleshooting steps:

  • Turned off/on the monitor
  • Unplugged/plugged in the DP cable (both ends)
  • Reset the monitor (OSD)
  • Tried a different DP cable (bundled DP / KabelDirekt DP 1.4)
  • Tried using a different computer with DisplayPort
  • Updated the firmware of the monitor (now running 1008)
  • Dropped the DP setting to 1.2 and 1.1 (OSD)

Any assistance would be greatly appreciated. 

3 Replies
user2UfibpKIrc
Astronaut
Options
Monitors and Memory

Same issue here.

HDMI 2.1 is pushing 144Hz no problem. DP, however, no signal found. Goes into standby mode. 

Plugging it into the back of my RTX 3080 Ti and nothing.

Updated the software to 1011 via USB FAT32 flash drive through the service port on the back of the monitor...

userxZPq6avjHv
Asteroid
Options
Monitors and Memory

I updated to 1011 as well and it is still a problem. I am returning the monitor for a refund. It's a real shame given how awesome it is, but for the price, I cannot accept a non-functioning port that I would prefer to use.

Solution
Samsung_Moderator
Community Manager
Community Manager
Options
Monitors and Memory

I can definitely understand your concern here. Let's try to alleviate some of the stress by trying this link: https://www.samsung.com/us/support/troubleshooting/TSG01110761/ If this does not help I recommend letting a service technician have a look. As we would like to gather additional information, and look at this from a case by case basis please provide the full model code and serial number of the device as well as your best contact phone number, name, and email.  
 
Send a message on Facebook 
 
Send Message on Twitter 
 
Send Message to Moderator