cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
user4bxQCJT2vK
Constellation

970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

Hey,

 

Bought a 970EVO and doing some pre-deployment testing of iEEE1667 encryption.  I am also having bad luck with our Intel 7600p drives doing this - another story.

 

Anyway, I have the drive installed on a PC with nvme slot and Magician 5.2 is telling me it is not supported.  Anyone else got the 970EVO to work with their Magician software?  I need Magician to enable edrive capability for bitlocker hardware encryption (unless Samsung had a CLI tool for doing this?).  

 

I did download the Samsung nvme 3.0 driver and installed with same result.

 

I did call Samsung support which was knowledgable, but did not offer anything useful.

 

Thanks for any help.

1 SOLUTION

Accepted Solutions
userUjgLM4rMTX
Astronaut

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

If your bios is set to "raid on" then you must change it to "AHCI" in order to install latest version of samsung firmware and get samsung magician to recognize your drive.  If you just change the values in your bios, you will get blue screen of death; you need to do it this way: 

 

https://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-oper...

 

This worked very well for me for this issue.  Nothing to do with clearing secure boot keys.

Reply
Loading...
24 REPLIES 24
Eaton
Constellation

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

Samsung Magician 5.3 supports the new drives, but it strangely hasn't been released pubicly yet.Smiley Indifferent

Reply
Loading...
userPM944HmrfK
Asteroid

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

Magician 5.2 working with 970 EVO for me on Asus X99-A II motherboard.

Reply
Loading...
userIxGjOpPXVU
Constellation

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

5.2 worked for me initially. I optimized with it, over provisioned.  But--now it says "UNKNOWN DRIVE". Reinstalled, refreshed, nothing.

 

 

Reply
Loading...
Kbird
Asteroid

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

@userPM944HmrfK wrote:

Magician 5.2 working with 970 EVO for me on Asus X99-A II motherboard.


 

Same MB and SM 5.2.1 working here on a new EVO970 with 1B2QEXE7  FW

Reply
Loading...
userZ8INFyFeJr
Constellation

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

It doesn't inspire much confidence that the company's own disk tool has so much trouble recognizing its own drives.

 

Evo 970, Gigabyte Gaming 5 mother board.  Drive seems to work fine in Windows and everywhere else, but Magician sees it as "unsupported".

Reply
Loading...
djjuice
Cosmic Ray

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

i had this issue with my 970 pro.

 

i had to uninstall magician and re-install it for it to show up.

Reply
Loading...
userIxGjOpPXVU
Constellation

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

I reinstalled it several times, same problem. 

Reply
Loading...
userUjgLM4rMTX
Astronaut

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

If your bios is set to "raid on" then you must change it to "AHCI" in order to install latest version of samsung firmware and get samsung magician to recognize your drive.  If you just change the values in your bios, you will get blue screen of death; you need to do it this way: 

 

https://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-oper...

 

This worked very well for me for this issue.  Nothing to do with clearing secure boot keys.

Reply
Loading...
uservvjy8cNyuq
Astronaut

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

In my case the following worked:

1. Switching from RAID to AHCI mode according to your instructions

2. Installing NVME driver from Samsung website

 

Reply
Loading...