cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Astronaut

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

Thank you userUjgLM4rMTX for sharing the article. magician now can detect my NVMe 970 evo on Acer Predator Helios 300.

Reply
Loading...
Highlighted
Constellation

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

 Hi all,

 

I think the issue is this...

 

For the 970 drives to be recognised by Magician, they need the NVMe driver to be installed.

 

If like me you have a motherboard that supports Intel Optane, I dont seem to have a BIOS option to disable RAID. Its not using RAID, but the BIOS on my HP has that as the only option.

 

If the BIOS is set to RAID, you can't install the NVMe driver. 

 

I might be wrong, but this looks like the most likely option.

Reply
Loading...
Highlighted
Asteroid

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

I can't say for sure but my system uses RAID on a Asus X99A-II and has had no issues with the 960 Evo or 970 EVOs currently in it ( 960 on Riva PCIe Riser Board).....the caveat there though is the Bios has no hint whatsoever that either NVME Drive is installed....1st time I booted I thought I had an issue as 1st thing I did was enter the bios to see if it was detected but I couldn't find it....but windows had no Issues. Currently using the NVME V.3 Driver that was release for Windows 1803 in April.

 

Currently I have SM 5.2.1. installed but I don't use it actively for Over Provisioning etc.

 

It is telling me both the 970 and 960 have Firmware Updates available (860 too) but after the issues earlier this year with that, I am dubious about installing any of them since they are working and I don't need e-Drive or Bitlocker which is all I think the Updates are For?

Reply
Loading...
Highlighted
Astronaut

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

Perfect thanks for your post.

 

Kind regards Lillifechen -https://labarti.de/

Reply
Loading...
Highlighted
Constellation

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

I'm using SM 5.3 and I am having the same issue.  I followed the instructons and have made the proper changes but SM is not recognizing my 970EVO(pm981).  I have an ASUS Zenith extreme with 1601 UEFI bios.  Any thoughts or updates on this issue?  I am not looking to run RAID.  I do have my Win10 OS installed on the drive and it runs great.  Just want it to be recognized in Magician.

 

Thanks!

Reply
Loading...
Highlighted

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

Hi userldZEm56qsN,

 

What mode is your BIOS currently in? RAID, IDE or etc.

Reply
Loading...
Highlighted
Constellation

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

Thank you so much for this. This saved me a lot of frustration. I was about to start freaking out until I saw your post. I have done this multiple times, but with Optane this time it was different. 

Reply
Loading...
Highlighted
Constellation

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

AHCI savior ! Thanks man, finally got rid of this non supported since I installed Intel RST Optane thingy.

Reply
Loading...
Highlighted

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION

Thank you! I could not figure this out for the life of me and come to find out my Lenovo Yoga 730 defaulted to having Raid (RST) on in the bios.  Now I have to reinstall Windows dang it Lenovo.

Reply
Loading...
Highlighted
Constellation

Re: 970 EVO not compatible with Magician 5.2?

JUMP TO SOLUTION
Asus X299 with two M.2 slots, both NVME, my 960 PRO is recognized, my new 970 EVO is NOT recognized.

Magician version 5.2.1 (Latest).
Reply
Loading...