JUMP TO SOLUTION Solved

Original topic:

Spotify Media Output notification won't go away

(Topic created: 09-29-2022 01:28 PM)
62468 Views
Fairela
Cosmic Ray
Options
Galaxy S21

I've tried deleting Spotify and reinstalling it and this notification keeps reappearing in my tray after I've dimissed it. I can't get it to go away. I'm not even listening to Spotify right now! The app is closed. Why does this continue to appear there? 

 
***Edited to add that the following steps solved the problem for me:
 
1. Go to Settings on your phone (phone is on OS 13)
2. Select "Apps" 
3. Select the filter/sort icon next to the "Your apps" header above the list of app results 
4. Turn the "Show system apps" toggle to ON 
5. Select "OK" 
6. Scroll to "Media and devices" in the list of app results and select it 
7. Select "Notifications" 
8. Select "Nearby Devices" under "Allowed" 
9. Select "See all apps with this permission"
10. Locate and select the offending app (in my case, this was Spotify)
11. Select the "Deliver quietly" option for the app
JUMP TO SOLUTION
Akuula
Asteroid
Options
Galaxy S21
The same thing happens to me😭. I hate it. I listen to Pandora, and it just keeps making it sound like I received a message, and during change of songs it makes multiple notification sound. Another annoying thing that it adjusts volume on it's own it will quiet and next moment it will blasting. I hate new update. It all started after update
MarottaTwangDang
Constellation
Options
Galaxy S21

For  sake how do we get rid of this??? Maybe it's called " This phone " that's what it says with a music note by it . So it's definitely a system thing

Fairela
Cosmic Ray
Options
Galaxy S21
If it helps, I think this might also have something to do with connecting to a Bluetooth speaker. I swear this started happening after I played Spotify from my phone on a Bluetooth speaker. I haven't tried messing with that though since the steps provided in the Accepted Solution of this post fixed the issue for me.
0 Likes
Reply
DoeBoy3
Constellation
Options
Galaxy S21

This is also happening on my phone, and it seems to have started after a recent update.  For me, it's the Audible app. I thought it was Audible's issue, but it appears it's just Samsung's UI.  Whenever I restart my phone, a notification for Media controls keeps appearing for Audible. I can't get rid of it. It's annoying as  and I don't want anything just auto appearing.  Even if I do a long press on the notification and click on Remove, it comes back the next time I restart my phone.

This is asinine.

It started on my Galaxy S21 Ultra after a recent update, and has now carried over to my new S23 Ultra.

If it even matters, it's an AT&T branded phone.

 

 
Zuk999
Constellation
Options
Galaxy S21
This just started happening to me after I installed Iheartradio app and linked it to my Alexa echo using Bluetooth. It won't go away even when no music is playing. It keeps showing a paused playlist on my Alexa app which is so confusing and annoying. Samsung please fix!
0 Likes
Reply
userMuk5OpE7Nh
Constellation
Options
Galaxy S21
As of 4.24.23, I discovered that to get rid of the media output notification in the drop down bar, (Spotify, for example), I just needed to swipe it right. This was on a GalaxyS23.
Discovered this after spending way too much time hunting through all of the app settings. 🤦🏼🥴
0 Likes
Reply
Calivornia
Constellation
Options
Galaxy S21

Long press the notification

userMWJtFy2ra4
Asteroid
Options
Galaxy S21

Long pressing it DOES remove it, but it always comes back, after a restart or after listening to Spotify.  I wish, like other users here, it would just go away....I have a z flip 4, but the same issue as the galaxy 21 owners here.

 

 

 

 

 
0 Likes
Reply
userMWJtFy2ra4
Asteroid
Options
Galaxy S21

I did find a 'solution'.  Stops player from coming back once you swipe it away, though it will pop up again when you use Spotify (you just swipe it away again).   I don't think there's a way to permanently stop it from popping up....I blocked notifications from Spotify in every way imaginable and the player still comes back after using Spotify.  BUT, this 'solution' will KEEP it from coming back if you DON'T use spotify - like I said, if you use it, swipe it away or long-press the player to remove it.

You need to use Nova Launcher, which is a home screen replacement that works great.  Gives you a lot more functionality than the stock home screen.  You can download it on Play Store.

I have OS13 on my z flip 4.  Not sure if this works for previous OS.

When you have the Launcher installed, 

-go to your home screen, in a blank area long press until you see 'Widgets' pop up, among other things (Wallpapers, Settings).  Open Widgets - you may have to swipe up to open it.   

-You'll see a bunch of widgets displayed, usually in alphabetical order.  go to the 'Activity' widget and long-press the icon.  You can now move the icon....place it on a blank area of your home screen.

-You'll be transported to a long list of drop down items.....scroll down to 'Settings' and click on it.

-this opens another long list of drop down items, in alphabetical order.  Scroll down to 'Media' and tap it.

-this takes you back to the home screen.  You now should have a 'Media' icon on your screen.  Tap it.

-mine has two selections, 'Pin media player', and 'Show media recommendations'.  I turned off both, but the 'Pin media player' is the one you obviously want.

Once you do that your media player should stop popping up all the time, EXCEPT when you use Spotify - then you just swipe/long press it away.  

Hope this helps.

 

 

 

 

 
userTnJU8gu1uJ
Constellation
Options
Galaxy S21
I noticed it right after I hooked my phone up to my car. I didn't do it for the 1st 3 weeks, when I first got my S23. I connected them 3 days ago, and that's when it started.
0 Likes
Reply